<!doctype html><!--[if IE 8]><html class="no-js lt-ie10 lt-ie9" lang="en"><![endif]--><!--[if IE 9]><html class="no-js lt-ie10" lang="en"><![endif]--><!--[if gt IE 10]><!--><html class="no-js" lang="en" ><!--<![endif]--><head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/js/partner/show_ads.js"></script><title>How Jim Harbaugh’s University of Michigan football recruits are working out</title><meta content="text/html; charset=UTF-8" name="Content-Type" /><meta name="google" content="notranslate"><meta name="apple-itunes-app" content="app-id=904391210"><meta name="description" content="While there are still a handful of players who were recruited before Jim Harbaugh and his staff got to Ann Arbor, the vast majority of the roster is now his recruits."><link rel="canonical" href="https://www.detroitnews.com/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/"><link rel="amphtml" href="https://amp.detroitnews.com/amp/766335002" /><meta property="fb:app_id" content="175422022549521"/><meta property="fb:pages" content="6271782579,6566864515,6581478870,7197664863,7850621533,8031989578,9812439851,10482066215,11277320498,13642915529,13652355666,14073085963,16511263815,17540977705,18884137648,19125738813,23332504801,25003338948,31185662683,36808884697,37412800032,41044579289,42128399297,43612894510,46050757230,47020221001,47692649063,48490808881,48958576760,48976713989,49060990988,49607602899,49680588265,49896855793,50095226239,50978409031,52929678682,54660221594,55529405081,56434454301,56732457944,62464848082,62811590881,63475094632,63475094632,63582312713,65299040658,66049156099,66281684861,68903794473,69357466992,70423731350,70657021294,71807382333,72088679443,72139486384,73736978810,74475819815,76240820015,76276576343,77475586904,79333461561,79437403137,80117331717,80335432797,81086717085,81320873283,81668556783,81917682064,82415033847,83300095936,83563566820,87171906471,87448932499,87448932499,88584644204,90329609573,94480694479,94700656192,95712466848,95926318753,97657252278,99020906334,100825602361,101112717264,103261740968,103678546758,104331357951,104935809704,105714200321,105814368912,105878288262,106644919984,107327575587,108555442934,109146355881,109686244216,109793107867,110252103235,110404119877,110527555449,115611960606,115967868757,117907407522,118427210363,121866005065,122786733297,124755637015,125551044242,126226324691,129236178055,132159529312,132779306963,133049345480,134076752154,134394490084,136737914809,138770030135,141962110815,146089950343,148668982786,152774630192,153308622465,158094820767,164935760159,168684165430,173007618420,182922701188,188894693348,189867939238,190632318566,201996980631,227627281180,231239152914,242752084180,250325640686,264717798098,274620738925,275678631915,312966181232,314817944972,319611510288,323213251787,329923389135,338437548341,347221378913,362300531934,363363051861,371547464003,385926141498,427414745045,488720200095,100855786673970,105233922869839,105347532857165,105550656158763,106451856091222,106819879363130,107117249323169,108029922557289,108981615791456,109280192597421,109280192597421,109652569058713,110311752340743,110471702456365,110743725611909,110936258937026,111203872270080,112875149052352,113056925415668,113544088682099,113819202011100,115535341805950,115612465136194,117941352212869,119027288135308,119794264705307,119941731380546,120356424669462,121160355264720,121227371225765,121242251236815,121422567927897,124075397608772,124307640925620,124528254305153,127729820590459,128075747844406,129752560371732,130211193676772,130407246974813,130934216964240,136941796341905,137098406340114,137341919636249,137698179626815,137935586280481,138064052876960,138170199553897,140615052641118,140616965982144,141822679203700,142195472502819,143851392316295,145525478832716,146112055409819,146137498764266,146315142126130,146798045922062,147760805252234,148251148521543,149641051719383,152527031492851,152785861474173,153525871324757,154425934607982,154443518023678,155874144456588,156345381090801,157305941529632,157456661011568,158095147555989,159385590790009,160735830621443,161639923860040,165912253479205,167334979948476,167487199962004,169254356561132,169571899725267,169908223021026,176115302489104,176983469019018,177037772444433,177938742707529,180004588791896,183850168300771,183882195384562,184094471609920,184741935370451,185457134911754,187466604613310,187899791275353,190953458083653,192069610842446,196267627213508,197490563626275,205576782811630,207319989616043,209524799494208,212808112063652,220757414638542,222348701505747,224163964346315,225067797622802,225571757789261,225618707473378,231988790171331,235484153604672,236655713446291,236665340121443,241091022598958,243031846042424,251228454889939,261119230567728,263714980315631,279914708715884,281030418652036,281331052320274,285377081517877,288382484929799,288570077828603,295018040526596,297522096960113,305068052985746,307826419595702,310942265948388,315461641910509,315942225236045,315942225236045,320453738073595,321223331243188,327249521057460,330565860307724,332382433821098,334297859927211,339575256116022,351359635259904,353404615129492,368424599844024,373087836097009,399493863726488,401783903349050,405292372992577,410195352524708,412113499123835,420941268096348,421255071314156,422375144525783,426754640812333,438452439879553,458808827485318,469694573429026,471891632935599,477690595750196,480464022311783,487732368292520,510151039081225,535045576657973,535551216797440,556150611109468,562348203875693,566432520196581,569900189687627,581529871999163,592673674105043,593739520831583,611437275717153,637561026326153,642020402627050,677476185677499,686958778091339,704313986314492,717947288315597,756473301219510,757336147711096,813218208713830,850378298431411,872296879526971,877111212410602,911836215623184,917342785050040,927427260614748,945986872102221,1561238324154800,1822461518079800,1889753241275160,1003311406396687,1007667299356254,1095671673874517,1111939365618797,1170250869768985,1199725526840512,1203830176364044,1224613924286312,1244424538911767,1260369167415906,1282648301845288,1413320388972813,1422299337837954,1425793144356745,1432665186743737,1443524575938047,1473996709497771,1504884589584087,1525148737812812,1526198127405784,1583851541911383,1588113081458198,1596218533974035,1602646926431957,1603698749645413,1621466394844549,1627621717510471,1667234726635829,1725861847686522,1747180218844657,1759005871036426,1774393409526131,1797367867256626,1847787168808886,1878073225844519,1946209538938897,1972936962947967,2047091012096533" ><meta property="og:site_name" content="Detroit News" /><meta name="ROBOTS" content="NOODP, NOYDIR" /><meta property="og:image" content="https://www.gannett-cdn.com/-mm-/d00b79de46844be46bc3184f6ccf6f07d7c3eba8/c=0-155-4085-2463/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666484138964189-2017-1104-dg-UM0564.jpg?width=3200&height=1680&fit=crop"/><meta property="og:image:width" content="3200"/><meta property="og:image:height" content="1680"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://www.gannett-cdn.com/-mm-/d00b79de46844be46bc3184f6ccf6f07d7c3eba8/c=0-155-4085-2463/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666484138964189-2017-1104-dg-UM0564.jpg?width=1600&height=800&fit=crop"/><meta property="og:image" content="https://www.gannett-cdn.com/media/2018/02/09/DetroitNews/DetroitNews/636537661891251984-detroitnews.png"/><meta name="twitter:site" content="@detroitnews" /><meta name="twitter:creator" content="@detroitnews" /><meta name="twitter:title" content="How Jim Harbaugh’s Michigan recruits are working out" /><meta name="twitter:description" content="While there are still a handful of players who were recruited before Jim Harbaugh and his staff got to Ann Arbor, the vast majority of the roster is now his recruits." /><meta property="og:title" content="How Jim Harbaugh’s Michigan recruits are working out"/><meta property="og:description" class="speakable-description" content="While there are still a handful of players who were recruited before Jim Harbaugh and his staff got to Ann Arbor, the vast majority of the roster is now his recruits."/><meta property="og:url" content="http://ux.detroitnews.com/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/"><meta property="og:type" content="article"/><script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "headline": "How Jim Harbaugh’s Michigan recruits are working out",
        "description": "While there are still a handful of players who were recruited before Jim Harbaugh and his staff got to Ann Arbor, the vast majority of the roster is now his recruits.",
        "url": "https://www.detroitnews.com/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/?utm_source=google&utm_medium=amp&utm_campaign=speakable",
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://www.detroitnews.com/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/"
        },
        "thumbnailUrl": "https://www.gannett-cdn.com/-mm-/2c79688bc53497ff6b8ccd4b5dae5294b8985a54/c=566-0-3293-2727/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666484138964189-2017-1104-dg-UM0564.jpg?width=150&height=150&fit=crop",
        "image": {
            "@type": "ImageObject",
            "url": "https://www.gannett-cdn.com/-mm-/d00b79de46844be46bc3184f6ccf6f07d7c3eba8/c=0-155-4085-2463/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666484138964189-2017-1104-dg-UM0564.jpg?width=1600&height=800&fit=crop",
            "height": 800,
            "width": 1600
        },
        "dateCreated": "2018-07-08T16:17:32.683Z",
        "dateModified": "2018-07-09T09:21:34.937Z",
        "datePublished": "2018-07-08T16:17:32.683Z",
        "articleSection": "sports",
        "publisher": {
            "@type": "Organization",
            "name": "The Detroit News",
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.gannett-cdn.com/sites/detroitnews/images/site-nav-logo@2x.png",
                "height": 80,
                "width": 297
            }
        },
        "author": ["By Allen Trieu"],
        "keywords": ["Section:sports:college","Type:story"]
        
    }
    </script><meta name="viewport" content="width=1070" /><link rel="shortcut icon" href="https://www.gannett-cdn.com/sites/detroitnews/images/favicon.png"><!--[if gt IE 9]><!--><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/css/bundles/main_modern.min.css"><link data-identifier="sports" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/css/bundles/sports.min.css"><link data-identifier="sports-logos" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/css/bundles/sports-logos.min.css"><!--<![endif]--><!--[if IE 9]><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/css/bundles/common.min.css"><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/css/bundles/main.min.css"><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/css/bundles/dynamic.min.css"><link data-identifier="sports" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/css/bundles/sports.min.css"><link data-identifier="sports-logos" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/css/bundles/sports-logos.min.css"><![endif]--><!--[if IE 8]><link data-identifier="main" rel="stylesheet" href="/uxstatic/detroitnews-web-static-2529.0/css/bundles/common.min.css"><link data-identifier="main" rel="stylesheet" href="/uxstatic/detroitnews-web-static-2529.0/css/bundles/main.min.css"><link data-identifier="main" rel="stylesheet" href="/uxstatic/detroitnews-web-static-2529.0/css/bundles/dynamic.min.css"><link data-identifier="sports" rel="stylesheet" href="/uxstatic/detroitnews-web-static-2529.0/css/bundles/sports.min.css"><link data-identifier="sports-logos" rel="stylesheet" href="/uxstatic/detroitnews-web-static-2529.0/css/bundles/sports-logos.min.css"><![endif]--><link rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/css/print.css" media="print"><!--[if gt IE 8]><!--><style>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</style><!--<![endif]--><!--[if lt IE 9]><link rel="stylesheet" href="/services/css/configs.css"><![endif]--><style></style><!--[if lt IE 9]><script src="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/js/libs/html5shiv-printshiv.js"></script><script src="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/js/libs/respond/respond.min.js"></script><![endif]--><script type="text/javascript">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</script><script type="text/javascript">
	// 86acbd31cd7c09cf30acb66d2fbedc91daa48b86:1508955651.24
	!function(n,t,c,e,u){function r(n){try{f=n(u)}catch(n){return h=n,void i(p,n)}i(s,f)}function i(n,t){for(var c=0;c<n.length;c++)d(n[c],t);
	}function o(n,t){return n&&(f?d(n,f):s.push(n)),t&&(h?d(t,h):p.push(t)),l}function a(n){return o(!1,n)}function d(t,c){
	n.setTimeout(function(){t(c)},0)}var f,h,s=[],p=[],l={then:o,catch:a,_setup:r};n[e]=l;var v=t.createElement("script");
	v.src=c,v.async=!0,v.id="_uasdk",v.rel=e,t.head.appendChild(v)}(window,document,'https://web-sdk.urbanairship.com/notify/v1/ua-sdk.min.js',
	  'UA', {"defaultActionURL": "http://www.detroitnews.com/", "appKey": "q-hcDmKpT2WYu6Ccl_EFUA", "defaultIcon": "https://www.gannett-cdn.com/mobile-web/uscp-mobile/v1/detroitnews/images/android-icon@2x.png", "defaultTitle": "The Detroit News", "enabled": true, "vapidPublicKey": "BIw5GdzQrsiD0GIsAQGsiPBGaaInWSxcOJ8Widm7ar4hgRxORXQmokrdN3FUdYzs389eCd5ypio38R58l2SpLNA=", "token": "MTpxLWhjRG1LcFQyV1l1NkNjbF9FRlVBOlFGYzNGdmFDV3RoYTM5TDItbFNiSHpzbElpc25iV3hJZWQyTWxCX1k4WFU"});

	function getChromeVersion () {     
		var raw = navigator.userAgent.match(/Chrom(e|ium)\/([0-9]+)\./);
		return raw ? parseInt(raw[2], 10) : false;
	}

	UA.then(function(sdk) {
		// Use more permanent storage to know if they've been here in the past at all
		var isReturnedUser = !!window.localStorage.getItem("ua:isReturnedUser");
		window.localStorage.setItem("ua:isReturnedUser", true);

		// Use session based storage to detect if this is the first view of the session
		var isFreshSession = !window.sessionStorage.getItem("ua:isReoccuredSession");
		window.sessionStorage.setItem("ua:isReoccuredSession", true);

		if (isReturnedUser && isFreshSession && getChromeVersion() >= 56){
			sdk.register();
			if (sdk.channel) {
				sdk.channel.tags.add("segmentable");
				sdk.channel.tags.add("breaking_news");
			}
		}
	});
	</script><script type="text/javascript" src="//try.abtasty.com/b65cbe43558ab726cbf552af4a9f756f.js"></script></head><body class=" site-theme-maroon" ><header data-fixed="false" data-open="true" data-default-fixed="false" data-default-open="true" class=" site-header "><div class="site-header-inner-wrap " style="background: rgb(178,31,39);"><div class="site-masthead" style="background: rgb(178,31,39);"><a class="site-masthead-logo-link logo-link" data-ht="Headerdetroitnews Headerlogoexpanded" href="/" ><img class="site-masthead-logo-img" src="https://www.gannett-cdn.com/sites/detroitnews/images/site-masthead-logo@2x.png" height="80" alt="Detroit News"></a><div class="site-masthead-search-wrap"><form class="site-masthead-search-form ui-ajax-form" action="/search/" method="get" data-mapping="<%= q %>/"><div class="site-masthead-search-input-wrap ui-form-field-container"><input class="site-masthead-search-form-input ui-text-input" data-clearable="true" type="text" name="q" autocomplete="off" placeholder="Search"><div class="site-masthead-search-btn site-masthead-search-btn-div" data-ht="Headersearchbutton"></div></div><input class="site-masthead-search-btn submit" type="submit" value="Search"><span class="site-masthead-search-close-btn" data-uotrack="Headersearchclosebutton"></span><div class="site-masthead-subscribe-wrap site-masthead-subscribe-wrap-visible"><a href="https://subscribe.detroitnews.com" class="userAuth-redirect site-masthead-subscribe-link" data-ht="Headersubscribecallout" target="_blank"><span class="site-masthead-subscribe-primary-text">Subscribe Now</span><span class="site-masthead-subscribe-secondary-text">for about $2.99 Per Week</span></a></div><div class="site-masthead-special-offers-ad partner-placement"></div></form></div></div><nav class="site-nav"style="background: rgb(81,81,81); border-top-color: rgb(115,108,100);"><ul class="site-nav-list"><li class="site-nav-item site-nav-end-item site-nav-logo-item"><a class="site-nav-link site-nav-logo-link" data-ht="Headerlogocollapsed" href="/"  ><img class="site-nav-logo-img " src="https://www.gannett-cdn.com/sites/detroitnews/images/site-nav-logo@2x.png" height="40" alt="Detroit News"></a></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-primary-item site-nav-end-item site-nav-first-primary-item site-nav-text-item site-nav-home-item site-nav-module site-nav-home-module" id="module-position-RAmNJvQZPaA" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-maroon site-nav-end-link site-nav-first-primary-link site-nav-text-link site-nav-home-link" href="/" data-ht="Headerhome" style="border-color: rgb(115,108,100);"><span class="site-nav-span site-nav-span-theme-maroon site-nav-end-span site-nav-first-primary-span site-nav-text-span home-theme-bg-hover maroon-theme-bg-hover site-nav-home-span">Home</span><span class="site-nav-theme-border home-theme-bg maroon-theme-bg" style="background-color: rgb(115,108,100) !important;"></span></a></span></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-primary-item site-nav-text-item site-nav-news-item site-nav-module site-nav-news-module" id="module-position-RAmNJvQ2HJ8" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-maroon site-nav-text-link site-nav-news-link" href="/news/" data-ht="Headernews" style="border-color: rgb(115,108,100);"><span class="site-nav-span site-nav-span-theme-maroon site-nav-text-span news-theme-bg-hover maroon-theme-bg-hover site-nav-news-span">News</span><span class="site-nav-theme-border news-theme-bg maroon-theme-bg" style="background-color: rgb(115,108,100) !important;"></span></a></span></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-primary-item site-nav-text-item site-nav-sports-item site-nav-module site-nav-sports-module" id="module-position-RAmNJvR4g-c" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-maroon site-nav-text-link site-nav-sports-link" href="/sports/" data-ht="Headersports" style="border-color: rgb(115,108,100);"><span class="site-nav-span site-nav-span-theme-maroon site-nav-text-span sports-theme-bg-hover maroon-theme-bg-hover site-nav-sports-span">Sports</span><span class="site-nav-theme-border sports-theme-bg maroon-theme-bg" style="background-color: rgb(115,108,100) !important;"></span></a></span></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-primary-item site-nav-text-item site-nav-business-item site-nav-module site-nav-business-module" id="module-position-RAmNJvREI08" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-maroon site-nav-text-link site-nav-business-link" href="/business/" data-ht="Headerbusiness" style="border-color: rgb(115,108,100);"><span class="site-nav-span site-nav-span-theme-maroon site-nav-text-span business-theme-bg-hover maroon-theme-bg-hover site-nav-business-span">Business</span><span class="site-nav-theme-border business-theme-bg maroon-theme-bg" style="background-color: rgb(115,108,100) !important;"></span></a></span></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-primary-item site-nav-text-item site-nav-autos-item site-nav-module site-nav-autos-module" id="module-position-RAmNJvQFlPA" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-maroon site-nav-text-link site-nav-autos-link" href="/autos/" data-ht="Headerautos" style="border-color: rgb(115,108,100);"><span class="site-nav-span site-nav-span-theme-maroon site-nav-text-span autos-theme-bg-hover maroon-theme-bg-hover site-nav-autos-span">Autos</span><span class="site-nav-theme-border autos-theme-bg maroon-theme-bg" style="background-color: rgb(115,108,100) !important;"></span></a></span></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-primary-item site-nav-text-item site-nav-life-home-item site-nav-module site-nav-life-home-module" id="module-position-RAmNJvR1M_8" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-maroon site-nav-text-link site-nav-life-home-link" href="/life-home/" data-ht="Headerlife-home" style="border-color: rgb(115,108,100);"><span class="site-nav-span site-nav-span-theme-maroon site-nav-text-span life-home-theme-bg-hover maroon-theme-bg-hover site-nav-life-home-span">Life + Home</span><span class="site-nav-theme-border life-home-theme-bg maroon-theme-bg" style="background-color: rgb(115,108,100) !important;"></span></a></span></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-primary-item site-nav-text-item site-nav-entertainment-item site-nav-module site-nav-entertainment-module" id="module-position-RAmNJvRdpn8" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-maroon site-nav-text-link site-nav-entertainment-link" href="/entertainment/" data-ht="Headerentertainment" style="border-color: rgb(115,108,100);"><span class="site-nav-span site-nav-span-theme-maroon site-nav-text-span entertainment-theme-bg-hover maroon-theme-bg-hover site-nav-entertainment-span">Entertainment</span><span class="site-nav-theme-border entertainment-theme-bg maroon-theme-bg" style="background-color: rgb(115,108,100) !important;"></span></a></span></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-primary-item site-nav-text-item site-nav-opinion-item site-nav-module site-nav-opinion-module" id="module-position-RAmNJvRUL4Q" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-maroon site-nav-text-link site-nav-opinion-link" href="/opinion/" data-ht="Headeropinion" style="border-color: rgb(115,108,100);"><span class="site-nav-span site-nav-span-theme-maroon site-nav-text-span opinion-theme-bg-hover maroon-theme-bg-hover site-nav-opinion-span">Opinion</span><span class="site-nav-theme-border opinion-theme-bg maroon-theme-bg" style="background-color: rgb(115,108,100) !important;"></span></a></span></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-primary-item site-nav-text-item site-nav-photo-video-item site-nav-module site-nav-photo-video-module" id="module-position-RAmNJvQ32Dw" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-maroon site-nav-text-link site-nav-photo-video-link" href="/media/latest/news/" data-ht="Headerphoto-video" style="border-color: rgb(115,108,100);"><span class="site-nav-span site-nav-span-theme-maroon site-nav-text-span photo-video-theme-bg-hover maroon-theme-bg-hover site-nav-photo-video-span">Photo + Video</span><span class="site-nav-theme-border photo-video-theme-bg maroon-theme-bg" style="background-color: rgb(115,108,100) !important;"></span></a></span></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-primary-item site-nav-end-item site-nav-last-primary-item site-nav-text-item site-nav-subscribe-item site-nav-module site-nav-subscribe-module" id="module-position-RAmNJvQrQno" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-maroon site-nav-end-link site-nav-last-primary-link site-nav-external-text-link site-nav-text-link site-nav-subscribe-link" href="http://offers.detroitnews.com/specialoffer?gps-source=CPTOPNAVBAR&amp;utm_medium=onsite&amp;utm_source=topnavbar&amp;utm_campaign=specialoffer" data-ht="Headersubscribe" target="_blank" style="border-color: rgb(115,108,100);"><span class="site-nav-span site-nav-span-theme-maroon site-nav-end-span site-nav-last-primary-span site-nav-text-span subscribe-theme-bg-hover maroon-theme-bg-hover site-nav-subscribe-span">Subscribe</span><span class="site-nav-theme-border subscribe-theme-bg maroon-theme-bg" style="background-color: rgb(115,108,100) !important;"></span></a></span></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-primary-item site-nav-more-item site-nav-text-item site-nav-module site-nav-text-module" id="module-position-" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-maroon site-nav-more-link site-nav-text-link" href="" data-ht="Headertext" style="border-color: rgb(115,108,100);"><div class="site-nav-span-wrap site-nav-more-span-wrap"><span class="site-nav-span site-nav-span-theme-maroon site-nav-more-span site-nav-text-span">More</span></div></a><div class="site-nav-dropdown site-nav-more-dropdown site-nav-more-dropdown-1col"><div class="site-nav-dropdown-inner-wrap site-nav-more-dropdown-inner-wrap"><ul class="site-nav-more-dropdown-list site-nav-more-dropdown-list-1col"><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/" data-ht="Headermorehome">Home</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/news/" data-ht="Headermorenews">News</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/sports/" data-ht="Headermoresports">Sports</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/business/" data-ht="Headermorebusiness">Business</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/autos/" data-ht="Headermoreautos">Autos</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/life-home/" data-ht="Headermorelife-home">Life + Home</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/entertainment/" data-ht="Headermoreentertainment">Entertainment</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/opinion/" data-ht="Headermoreopinion">Opinion</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/media/latest/news/" data-ht="Headermorephoto-video">Photo + Video</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="http://offers.detroitnews.com/specialoffer?gps-source=CPTOPNAVBAR&amp;utm_medium=onsite&amp;utm_source=topnavbar&amp;utm_campaign=specialoffer" data-ht="Headermoresubscribe">Subscribe</a></li></ul></div></div></span></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-primary-item site-nav-spacer-item site-nav-spacer-item site-nav-module site-nav-spacer-module" id="module-position-" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"></span></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-secondary-item site-nav-end-item site-nav-first-secondary-item site-nav-icon-item site-nav-firefly-item site-nav-module site-nav-firefly-module" id="module-position-RAmNJvR_5jM" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-maroon site-nav-end-link site-nav-first-secondary-link site-nav-external-icon-link site-nav-icon-link site-nav-firefly-link" href="https://account.detroitnews.com/" data-ht="Headerfirefly" target="_blank" style="border-color: rgb(115,108,100);"><div class="site-nav-span-wrap site-nav-icon-span-wrap"><span class="site-nav-span site-nav-span-theme-maroon site-nav-end-span site-nav-first-secondary-span site-nav-icon-span firefly-theme-bg-hover maroon-theme-bg-hover site-nav-firefly-span">Firefly</span></div><span class="site-nav-theme-border firefly-theme-bg maroon-theme-bg" style="background-color: rgb(115,108,100) !important;"></span></a><div class="site-nav-dropdown site-nav-firefly-dropdown"><div class="site-nav-firefly-dropdown-section ff-greetings"><p class="site-nav-firefly-dropdown-text ">Hi <span class="site-nav-firefly-user-display-name"></span></p></div><div class="site-nav-firefly-dropdown-section ff-login"><p class="site-nav-firefly-dropdown-text ">Already a subscriber?</p><a class="ui-chunky-btn secondary ff ff-login-btn firefly-signin-btn userAuth-redirect" rel="nofollow" data-ht="HeaderUserAuthLogin" data-user-account="firefly" href="https://login.detroitnews.com/PDTN-GUP/authenticate/?success-url=http%3A//ux.detroitnews.com/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/%3Fsrc%3Drss%253Fsrc%253Drss&cancel-url=http%3A//ux.detroitnews.com/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/%3Fsrc%3Drss%253Fsrc%253Drss">Log in</a></div><div class="site-nav-firefly-dropdown-section ff-subscribe"><p class="site-nav-firefly-dropdown-text ">Subscribe today for full access on your desktop, tablet, and mobile device.</p><a class="ui-chunky-btn ff subscribe-btn firefly-subscribe-btn userAuth-redirect" href="https://subscribe.detroitnews.com/?onSuccessRedirectURL=http%3A//ux.detroitnews.com/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/%3Fsrc%3Drss%253Fsrc%253Drss&gps-source=CPHPACCOUNT">Subscribe Now</a></div><div class="site-nav-firefly-dropdown-section ff-activate"><p class="site-nav-firefly-dropdown-text ">Already a print edition subscriber, but don't have a login?</p><a class="ff activate-btn firefly-activate-btn userActivate-redirect" data-user-account="firefly" href="https://subscribe.detroitnews.com/account-lookup/&requested-state=create-account">Activate your digital access.</a></div><div class="site-nav-firefly-dropdown-section ff-account"><p class="site-nav-firefly-dropdown-text ">Manage your account settings.</p><a class="ui-chunky-btn ff subscribe-btn firefly-subscribe-btn" data-user-account="firefly" data-track-label="hoveroversubscribe|myaccount" href="https://account.detroitnews.com/">My Account</a></div><div class="site-nav-firefly-dropdown-section ff-enewspaper hidden"><p class="site-nav-firefly-dropdown-text "><a class="ff" data-user-account="firefly" href="https://account.detroitnews.com/enewspaper/" target="_blank">View the E-Newspaper</a></p></div><div class="site-nav-firefly-dropdown-section ff-newsletters"><p class="site-nav-firefly-dropdown-text "><a class="ff" data-user-account="firefly" href="https://account.detroitnews.com/newsletters/" target="_self">Manage your Newsletters</a></p></div><div class="site-nav-firefly-dropdown-section ff-insider"><p class="site-nav-firefly-dropdown-text "><a class="ff" data-user-account="firefly" href="/insider/" target="_blank">View your Insider deals and more</a></p></div><div class="site-nav-firefly-dropdown-section ff-insider-idcard"><p class="site-nav-firefly-dropdown-text "><a class="ff" data-user-account="firefly" href="/insider/idcard" target="_blank">Member ID Card</a></p></div><div class="site-nav-firefly-dropdown-section ff-logout"><p class="site-nav-firefly-dropdown-text "><a class="ff-logout-btn userAuth-redirect" data-ht="HeaderUserAuthLogout" href="https://user.detroitnews.com/PDTN-GUP/user/logout/?return-url=http%3A//ux.detroitnews.com/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/%3Fsrc%3Drss%253Fsrc%253Drss">Log Out</a></p></div></div></span></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-secondary-item site-nav-icon-item site-nav-social-item site-nav-module site-nav-social-module" id="module-position-RAmNJvRNty0" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-maroon site-nav-icon-link site-nav-social-link" href="" data-ht="Headersocial" style="border-color: rgb(115,108,100);"><div class="site-nav-span-wrap site-nav-icon-span-wrap"><span class="site-nav-span site-nav-span-theme-maroon site-nav-icon-span social-theme-bg-hover maroon-theme-bg-hover site-nav-social-span"></span></div><span class="site-nav-theme-border social-theme-bg maroon-theme-bg" style="background-color: rgb(115,108,100) !important;"></span></a><div class="site-nav-dropdown site-nav-social-module-dropdown"><div class="social-dropdown-item facebook"><iframe src="//www.facebook.com/plugins/like.php?href=https%3A//www.facebook.com/DetroitNews&amp;width=450&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=true&amp;send=true&amp;appId=175422022549521" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:135px;" allowTransparency="true"></iframe></div><div class="social-dropdown-item twitter"><div class="twitter-follow"><a class="twitter-follow-label" href="https://twitter.com/intent/user?screen_name=detroitnews" target="_blank">Follow</a></div></div><div class="social-dropdown-item google-plus"><div class="g-follow" data-annotation="bubble" data-height="20" data-href="https://plus.google.com/105946933738933611322" data-rel="publisher"></div></div></div></span></li><li class="site-nav-item site-nav-item-theme-maroon site-nav-secondary-item site-nav-end-item site-nav-last-secondary-item site-nav-icon-item site-nav-search-item site-nav-module site-nav-search-module" id="module-position-RAmNJvQ2nPs" style="border-left-color: rgb(115,108,100);"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-maroon site-nav-end-link site-nav-last-secondary-link site-nav-icon-link site-nav-search-link" href="/search/" data-ht="Headersearch" style="border-color: rgb(115,108,100);"><span class="site-nav-span site-nav-span-theme-maroon site-nav-end-span site-nav-last-secondary-span site-nav-icon-span search-theme-bg-hover maroon-theme-bg-hover site-nav-search-span">Search</span><span class="site-nav-theme-border search-theme-bg maroon-theme-bg" style="background-color: rgb(115,108,100) !important;"></span></a></span></li></ul></nav><div class="bnm-container"></div></div><script type="json/headermodules" class="headermodules headermodules-primary">{ "js_modules": [{"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "RAmNJvQZPaA", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "RAmNJvQ2HJ8", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "RAmNJvR4g-c", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "RAmNJvREI08", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "RAmNJvQFlPA", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "RAmNJvR1M_8", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "RAmNJvRdpn8", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "RAmNJvRUL4Q", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "RAmNJvQ32Dw", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "RAmNJvQrQno", "options": null, "oembedprovider": null}] }</script><script type="json/headermodules" class="headermodules headermodules-secondary">{ "js_modules": [{"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "RAmNJvQ2nPs", "options": null, "oembedprovider": null}, {"name": "site-nav-social-module", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "RAmNJvRNty0", "options": null, "oembedprovider": null}, {"name": "site-nav-firefly-module", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "RAmNJvR_5jM", "options": null, "oembedprovider": null}] }</script></header><div id="overlay"><div class="partner-placement partner-gravity-ad partner-gravity-ad-"><div class="gravity-viewable" id="gravity-viewable"></div><div class="partner-scroll"><div class="partner-scroll-circle"></div><p class="partner-scroll-message">Get the news</p></div></div><div class="transition-wrap" ><div class="partner-placement partner-overlay-top-ad"></div><div class="partner-placement partner-sponsor-logo"></div><article class="asset story clearfix" ><div class="close-wrap"><a href="#" class="close close-overlay" data-ht="modalclose"></a></div><div class="utility-bar-wrap"><div class="utility-bar"><div class="util-bar-primary-modules"><div class="util-bar-module util-bar-module-share"><div
                    class="util-bar-btn util-bar-btn-facebook util-bar-btn-share"
                    data-module-name="utility-bar-module-share"
                    data-module-section="share"
                    data-uotrack="UtilityBarFacebookBtn"></div><a
                    class="util-bar-btn util-bar-btn-twitter"
                    data-module-name="share-twitter"
                    data-popup-width="550"
                    data-popup-height="450"
                    data-uotrack="UtilityBarTwitterLink"
                    href="https://twitter.com/intent/tweet?url=https%3A//detne.ws/2zmQh1O&amp;text=How%20Jim%20Harbaugh%E2%80%99s%20Michigan%20recruits%20are%20working%20out&amp;via=detroitnews"
                    target="_blank" data-popup
                    rel="nofollow"></a><a class="util-bar-btn util-bar-btn-linkedin"
                    data-share-method="linkedin"
                    data-popup-width="600"
                    data-popup-height="455"
                    data-uotrack="UtilityBarFlyoutLinkedInLink"
                    href="http://www.linkedin.com/shareArticle?url=https%3A//www.detroitnews.com/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/&amp;mini=true"
                    target="_blank" data-popup
                    rel="nofollow"></a><div
                    class="util-bar-btn util-bar-btn-email js-share-email-btn"
                    data-module-name="utility-bar-module-share"
                    data-module-section="email"
                    data-uotrack="UtilityBarEmailBtn"></div><div class="util-bar-flyout util-bar-flyout-share"><div class="util-bar-flyout-pane util-bar-flyout-pane-share scrollable-content"><div class="util-bar-flyout-heading util-bar-flyout-heading-share"><h6 class="util-bar-flyout-title util-bar-flyout-title-share">Share This Story!</h6><p class="util-bar-flyout-subtitle util-bar-flyout-subtitle-share">Let friends in your social network know what you are reading about</p></div><div class="util-bar-flyout-nav util-bar-flyout-nav-share"><span class="util-bar-flyout-nav-btn-wrap"><span
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-facebook active"
                                    data-share-method="facebook"
                                    data-uotrack="UtilityBarFlyoutFacebookBtn"
                                >Facebook</span></span><span class="util-bar-flyout-nav-btn-wrap"><span
                                        class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-email"
                                        data-share-method="email"
                                        data-uotrack="UtilityBarFlyoutEmailBtn"
                                    >Email</span></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-twitter"
                                    data-share-method="twitter"
                                    data-popup-width="550"
                                    data-popup-height="450"
                                    data-uotrack="UtilityBarFlyoutTwitterLink"
                                    href="https://twitter.com/intent/tweet?url=https%3A//detne.ws/2zmQh1O&amp;text=How%20Jim%20Harbaugh%E2%80%99s%20Michigan%20recruits%20are%20working%20out&amp;via=detroitnews"
                                    target="_blank" data-popup
                                >Twitter</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-googleplus"
                                    data-share-method="googleplus"
                                    data-popup-width="500"
                                    data-popup-height="500"
                                    data-uotrack="UtilityBarFlyoutGooglePlusLink"
                                    href="//plus.google.com/share?url=https%3A//www.detroitnews.com/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/"
                                    target="_blank" data-popup
                                >Google+</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-linkedin"
                                    data-share-method="linkedin"
                                    data-popup-width="600"
                                    data-popup-height="455"
                                    data-uotrack="UtilityBarFlyoutLinkedInLink"
                                    href="http://www.linkedin.com/shareArticle?url=https%3A//www.detroitnews.com/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/&amp;mini=true"
                                    target="_blank" data-popup
                                >LinkedIn</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                        href="//www.pinterest.com/pin/create/button/?url=https%3A//www.detroitnews.com/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/&media=https://www.gannett-cdn.com/-mm-/d00b79de46844be46bc3184f6ccf6f07d7c3eba8/c=0-155-4085-2463/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666484138964189-2017-1104-dg-UM0564.jpg?width=3200&height=1680&fit=crop&description=While there are still a handful of players who were recruited before Jim Harbaugh and his staff got to Ann Arbor, the vast majority of the roster is now his recruits."
                                        data-pin-do="buttonPin"
                                        data-pin-config="above"
                                        class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-pinterest"
                                        data-share-method="pinterest"
                                        data-popup-width="600"
                                        data-popup-height="455"
                                        data-uotrack="UtilityBarFlyoutPinterestLink"
                                        target="_blank" data-popup
                                        >Pinterest</a></span></div><div class="util-bar-share-summary"><img class="util-bar-share-summary-image" height="60" width="60" data-src="https://www.gannett-cdn.com/-mm-/2c79688bc53497ff6b8ccd4b5dae5294b8985a54/c=566-0-3293-2727/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666484138964189-2017-1104-dg-UM0564.jpg?width=60&height=60&fit=crop" alt="" /><h4 class="util-bar-share-summary-title">How Jim Harbaugh’s Michigan recruits are working out</h4><p class="util-bar-share-summary-description">While there are still a handful of players who were recruited before Jim Harbaugh and his staff got to Ann Arbor, the vast majority of the roster is now his recruits.</p></div><div class="util-bar-flyout-section util-bar-flyout-section-facebook"><form method="post" class="util-bar-share-form-facebook"><div
                                    class="util-bar-share-message-facebook"
                                    data-link="https://www.detroitnews.com/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/"
                                    data-image="https://www.gannett-cdn.com/-mm-/d00b79de46844be46bc3184f6ccf6f07d7c3eba8/c=0-155-4085-2463/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666484138964189-2017-1104-dg-UM0564.jpg?width=3200&height=1680&fit=crop"
                                    data-title="How Jim Harbaugh’s Michigan recruits are working out"></div><div class="util-bar-share-submit-wrap-facebook"><span class="util-bar-share-form-status-facebook"><img class="util-bar-share-loading-facebook" src="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/images/indicators/facebook-loading.gif" alt="Loading&hellip;"><span class="util-bar-share-status-text-facebook"></span></span><span class="util-bar-share-submit-btn-facebook">Post to Facebook</span></div></form></div><div class="share-email-container js-share-email-container"><div class="share-email-form-container js-share-email-form-container"><form action="/services/mail/v4/send/" method="post" class="share-email-form js-share-email-form"><input type="hidden" name="email_type" value="share_email" class="share-email-form-input "><input type="hidden" name="share_title" value="How Jim Harbaugh’s Michigan recruits are working out" class="share-email-form-input"><input type="text" name="your_name" class="email-to optional share-email-form-input ui-text-input" placeholder="Your Name"><input type="text" name="from" class="email-to required share-email-form-input ui-text-input "
                       placeholder="Your Email"><input type="text" name="to" class="email-from required share-email-form-input ui-text-input "
                       placeholder="Your Friend's Email"><textarea class="email-message share-email-form-textarea js-share-email-form-textarea ui-textarea " name="message"
                          placeholder="Message (optional)">How Jim Harbaugh’s Michigan recruits are working out &#13;&#13;While there are still a handful of players who were recruited before Jim Harbaugh and his staff got to Ann Arbor, the vast majority of the roster is now his recruits.  &#13;&#13;Check out this story on detroitnews.com: https://detne.ws/2zmQh1O</textarea><script src="https://www.google.com/recaptcha/api.js" async defer></script><div id="recaptcha-share" data-key="6LcLACIUAAAAAPLABOr22JCXRoTG-_lo3Nl8kFpv"></div><div class="email-form-buttons share-email-form-buttons"><span class="ui-chunky-btn secondary icon cancel share-email-form-cancel-btn js-share-email-cancel-btn">Cancel</span><span class="ui-chunky-btn icon send share-email-form-send-btn js-share-email-send-btn">Send</span></div></form></div><div class="share-email-success-pane js-share-email-form-success-pane"><h4 class="share-email-success-pane-title">Sent!</h4><p class="share-email-success-pane-description">A link has been sent to your friend's email address.</p></div></div></div><div class="util-bar-flyout-pane util-bar-flyout-pane-success util-bar-flyout-pane-success-facebook"><h4 class="util-bar-success-title util-bar-success-title-facebook">Posted!</h4><p class="util-bar-success-description util-bar-success-description-facebook">A link has been posted to your Facebook feed. </p></div><div class="util-bar-flyout-close-ribbon"></div></div></div><div class="util-bar-module util-bar-module-comments"><div
                        class="util-bar-btn util-bar-btn-comments"
                        data-uotrack="UtilityBarCommentsBtn"
                        data-module-name="utility-bar-module-comments"><span class="util-bar-comment-count">
                                9
                            </span></div><div class="util-bar-flyout util-bar-flyout-comments"><div class="util-bar-flyout-heading util-bar-flyout-heading-comments"><h6 class="util-bar-flyout-title util-bar-flyout-title-comments">Join the Conversation</h6><p class="util-bar-flyout-subtitle util-bar-flyout-subtitle-comments">To find out more about Facebook commenting please read the <a href="http://static.detroitnews.com/conversation-guidelines/">Conversation Guidelines and FAQs</a></p></div><div class="util-bar-comments-wrap"><div class="util-bar-scroll-wrap util-bar-scroll-wrap-comments  "><div class="facebook-comments-plugin-wrap scrollable-content"><div class="fb-comments" data-href="https://www.detroitnews.com/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/" data-posts="20" data-width="400"></div></div></div></div><div class="util-bar-flyout-close-ribbon"></div></div></div></div><div class="util-bar-secondary-modules"><div class="util-bar-module util-bar-module-print"><div
                        class="util-bar-btn util-bar-btn-print"
                        data-uotrack="UtilityBarPrintBtn"
                        data-module-name="utility-bar-module-print"></div></div></div></div></div><section id="module-position-RAmSvZTIDfU" class="storytopbar-bucket asset-nav-bar-module story-asset-nav-bar-module"></section><section id="module-position-RAmSvZU5bMM" class="storytopbar-bucket story-headline-module story-story-headline-module"><h1 class="asset-headline speakable-headline" itemprop="headline">How Jim Harbaugh’s Michigan recruits are working out</h1></section><section id="module-position-RAmSvZUgDxo" class="storytopbar-bucket priority-asset-module story-priority-asset-module"></section><section id="module-position-RAmSvZUeAVE" class="storytopbar-bucket story-byline-module story-story-byline-module"><div class="asset-metabar"><span class="asset-metabar-author asset-metabar-item">By Allen Trieu, Special to The Detroit News</span><span class="asset-metabar-time asset-metabar-item nobyline">
            Published 12:17 p.m. ET July 8, 2018 | <span class="asset-metabar-time-updated">Updated 5:21 a.m. ET July 9, 2018</span></span></div></section><section id="module-position-RAmSvZVoPgw" class="storytopbar-bucket piano-module story-piano-module"></section><section id="module-position-RAmSvZV8Xf4" class="storytopbar-bucket bounce-exchange-module story-bounce-exchange-module"></section><div class="asset-double-wide double-wide p402_premium" role="main" itemprop="articleBody"><div id="module-position-RAmSvb_PR4w" class="story-asset gallery-asset"><div class="card-film inactive"></div><div class="sidebar-gallery-btn active"></div><div class="companion-story-gallery js-llc" data-name="compStoryGallery"><div class="gallery-sidebar-panel"><span class="gallery-sidebar-close"></span><div class="gallery-sidebar-toolbox share-pane social-pane selected"><span class="util-bar-flyout-nav-btn-wrap"><span
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-facebook gallery-util-bar-flyout-nav-btn"
            href="#"
            target="_blank"
            data-share-link="https://www.detroitnews.com/picture-gallery/sports/college/university-michigan/2018/07/04/2019-michigan-football-commitments/36618301/"
            data-share-title=""
            data-share-method="facebook"
            data-uotrack="UtilityBarFlyoutFacebookBtn"
        >Facebook</span></span><span class="util-bar-flyout-nav-btn-wrap"><a
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-twitter gallery-util-bar-flyout-nav-btn"
            data-share-method="twitter"
            data-popup-width="550"
            data-popup-height="450"
            data-uotrack="UtilityBarFlyoutTwitterLink"
            href="https://twitter.com/intent/tweet?url=https://www.detroitnews.com/picture-gallery/sports/college/university-michigan/2018/07/04/2019-michigan-football-commitments/36618301/&amp;text=How%20Jim%20Harbaugh%E2%80%99s%20Michigan%20recruits%20are%20working%20out&amp;via=detroitnews"
            target="_popup"
        >Twitter</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-googleplus gallery-util-bar-flyout-nav-btn"
            data-share-method="googleplus"
            data-popup-width="500"
            data-popup-height="500"
            data-uotrack="UtilityBarFlyoutGooglePlusLink"
            href="//plus.google.com/share?url=https://www.detroitnews.com/picture-gallery/sports/college/university-michigan/2018/07/04/2019-michigan-football-commitments/36618301/"
            target="_popup"
        >Google+</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-linkedin gallery-util-bar-flyout-nav-btn"
            data-share-method="linkedin"
            data-popup-width="1000"
            data-popup-height="455"
            data-uotrack="UtilityBarFlyoutLinkedInLink"
            href="http://www.linkedin.com/shareArticle?url=https://www.detroitnews.com/picture-gallery/sports/college/university-michigan/2018/07/04/2019-michigan-football-commitments/36618301/&mini=true"
            target="_popup"
        >LinkedIn</a></span></div><div class="title gallery-sidebar-title selected">2019 Michigan football commitments</div><div class="gallery-sidebar-fullscreen"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen">&nbsp;</span>Fullscreen</a></div><div class="caption"></div><div class="gallery-sidebar-flyout-section util-bar-flyout-section util-bar-flyout-section-facebook"><form method="post" class="util-bar-share-form-facebook"><div
            class="util-bar-share-message-facebook"
            data-link="https://www.detroitnews.com/picture-gallery/sports/college/university-michigan/2018/07/04/2019-michigan-football-commitments/36618301/"
            data-title="How Jim Harbaugh’s Michigan recruits are working out"
            placeholder="Message (optional)"></div><div class="util-bar-share-submit-wrap-facebook"><span class="util-bar-share-form-status-facebook"><img class="util-bar-share-loading-facebook" src="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/images/indicators/facebook-loading.gif"><span class="util-bar-share-status-text-facebook"></span></span><span class="util-bar-share-submit-btn-facebook">Post to Facebook</span></div></form></div><div class="util-bar-flyout-pane util-bar-flyout-pane-success util-bar-flyout-pane-success-facebook"><h4 class="util-bar-success-title util-bar-success-title-facebook">Posted!</h4><p class="util-bar-success-description util-bar-success-description-facebook">A link has been posted to your Facebook feed. </p></div><div class="companion-galleries-partner-slot"></div></div><div class="companion-galleries embedded_story hasendslate galleries"
        data-gallery-id="36618301"
        data-title="2019 Michigan football commitments"
        data-seo-title="2019-michigan-football-commitments"
        data-ssts="sports/college/university-michigan"
        data-cst="sports/college/features_michigan"
        data-published-date="2018-07-04T18:36:42.157Z"
        
        data-topic="sports_big-ten"
         data-gal-pageurl="https://www.detroitnews.com/picture-gallery/sports/college/university-michigan/2018/07/04/2019-michigan-football-commitments/36618301/"><div class="viewport gallery-viewport"><div class="slide gallery-viewport-slide horizontal active"  itemprop="primaryImageOfPage"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal gallery-photo-first" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092719525142-umstock2.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/4044b1e7645488621f157de466cf1a990870caa2/r=500x333/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092719525142-umstock2.jpg" data-byline="David Guralnick, Detroit News"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/ca71e8023ea04ad765ffa93af0fa481373dae2b6/c=273-0-4554-3219/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092719525142-umstock2.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/ca71e8023ea04ad765ffa93af0fa481373dae2b6/c=273-0-4554-3219/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092719525142-umstock2.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Go through the gallery to view the Michigan football" data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Go through the gallery to view the Michigan football program's 2019 commitments (star ratings according to the 247Sports Composite).&#160;
                                    <meta itemprop="copyrightHolder" content="David Guralnick, Detroit News" /><span class="credit gallery-viewport-credit"> David Guralnick, Detroit News</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092649838088-ErickAll.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/b9916763085fe8f83433a77e9d5443140db5b58e/r=500x257/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092649838088-ErickAll.jpg" data-byline="247Sports"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/c05e6a49a30e8f3cb7fcc434cf1b3e2511a55a67/c=188-0-1011-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092649838088-ErickAll.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/c05e6a49a30e8f3cb7fcc434cf1b3e2511a55a67/c=188-0-1011-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092649838088-ErickAll.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Erick All, Fairfield (Ohio), TE, 6-4, 225 pounds, three" data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Erick All, Fairfield (Ohio), TE, 6-4, 225 pounds, three stars.&#160;
                                    <meta itemprop="copyrightHolder" content="247Sports" /><span class="credit gallery-viewport-credit"> 247Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092648588096-barnhart.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/c711c85d58e411988f13438d0dec93db9715f141/r=400x400/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092648588096-barnhart.jpg" data-byline="Twitter: @k_ballin_"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/ed783a0aa74c714a62e5aaf36356739ec52dceec/c=0-16-400-317/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092648588096-barnhart.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/ed783a0aa74c714a62e5aaf36356739ec52dceec/c=0-16-400-317/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092648588096-barnhart.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Karsen Barnhart, Paw Paw, OT, 6-4, 273 pounds, three" data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Karsen Barnhart, Paw Paw, OT, 6-4, 273 pounds, three stars.&#160;
                                    <meta itemprop="copyrightHolder" content="Twitter: @k_ballin_" /><span class="credit gallery-viewport-credit"> Twitter: @k_ballin_</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092648588096-carpenter.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/b9916763085fe8f83433a77e9d5443140db5b58e/r=500x257/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092648588096-carpenter.jpg" data-byline="247Sports"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/f3e073fa396d293a4f7ebdb11cd866df8b53fb5e/c=98-0-524-320/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092648588096-carpenter.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/f3e073fa396d293a4f7ebdb11cd866df8b53fb5e/c=98-0-524-320/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092648588096-carpenter.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Zach Carpenter, Cincinnati Archbishop Moeller, OG," data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Zach Carpenter, Cincinnati Archbishop Moeller, OG, 6-5, 310 pounds, three stars.&#160;
                                    <meta itemprop="copyrightHolder" content="247Sports" /><span class="credit gallery-viewport-credit"> 247Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663112542679523-charbonnet2.JPG" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/b9916763085fe8f83433a77e9d5443140db5b58e/r=500x257/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663112542679523-charbonnet2.JPG" data-byline="Brandon Huffman / 247 Sports"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/2e6f8d4f91fad3aab1a7a2ec67b9ae4575ad11d7/c=164-0-987-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663112542679523-charbonnet2.JPG?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/2e6f8d4f91fad3aab1a7a2ec67b9ae4575ad11d7/c=164-0-987-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663112542679523-charbonnet2.JPG?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Zach Charbonnet, Westlake Village (Calif.) Oaks Christian," data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Zach Charbonnet, Westlake Village (Calif.) Oaks Christian, RB, 6-2, 215 pounds, four stars.&#160;
                                    <meta itemprop="copyrightHolder" content="Brandon Huffman / 247 Sports" /><span class="credit gallery-viewport-credit"> Brandon Huffman / 247 Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092650150586-EricGray.JPG" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/b9916763085fe8f83433a77e9d5443140db5b58e/r=500x257/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092650150586-EricGray.JPG" data-byline="247Sports"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/17ad5a1f6fa2b86a33e014ecef0b90df49177127/c=196-0-1019-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092650150586-EricGray.JPG?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/17ad5a1f6fa2b86a33e014ecef0b90df49177127/c=196-0-1019-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092650150586-EricGray.JPG?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Eric Gray, Memphis (Tenn.) Lausanne Collegiate School," data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Eric Gray, Memphis (Tenn.) Lausanne Collegiate School, all-purpose back, 5-10, 191 pounds, four stars.&#160;
                                    <meta itemprop="copyrightHolder" content="247Sports" /><span class="credit gallery-viewport-credit"> 247Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092653431815-herron.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/b9916763085fe8f83433a77e9d5443140db5b58e/r=500x257/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092653431815-herron.jpg" data-byline="247Sports"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/b895739a24d61539c86a512e5270a2c3c333c9e4/c=153-0-976-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092653431815-herron.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/b895739a24d61539c86a512e5270a2c3c333c9e4/c=153-0-976-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092653431815-herron.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Stephen Herron Jr., Louisville (Ky.) Trinity, DE, 6-3.5," data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Stephen Herron Jr., Louisville (Ky.) Trinity, DE, 6-3.5, 235 pounds, four stars.&#160;
                                    <meta itemprop="copyrightHolder" content="247Sports" /><span class="credit gallery-viewport-credit"> 247Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092653744313-hinton.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/b9916763085fe8f83433a77e9d5443140db5b58e/r=500x257/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092653744313-hinton.jpg" data-byline="Twitter: @thechrishinton"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/c05e6a49a30e8f3cb7fcc434cf1b3e2511a55a67/c=188-0-1011-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092653744313-hinton.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/c05e6a49a30e8f3cb7fcc434cf1b3e2511a55a67/c=188-0-1011-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092653744313-hinton.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Chris Hinton, Norcross (Ga.) Greater Atlanta Christian," data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Chris Hinton, Norcross (Ga.) Greater Atlanta Christian, DE, 6-4, 280 pounds, five stars.&#160;
                                    <meta itemprop="copyrightHolder" content="Twitter: @thechrishinton" /><span class="credit gallery-viewport-credit"> Twitter: @thechrishinton</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092651088080-GJIII.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/b9916763085fe8f83433a77e9d5443140db5b58e/r=500x257/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092651088080-GJIII.jpg" data-byline="Andrew Ivins / 247 Sports"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/79d12606087f93beb2f3cdaa91f4da590757a6ce/c=107-0-930-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092651088080-GJIII.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/79d12606087f93beb2f3cdaa91f4da590757a6ce/c=107-0-930-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092651088080-GJIII.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="George Johnson III, Stuart (Fla.) Martin County, ATH," data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    George Johnson III, Stuart (Fla.) Martin County, ATH, 5-11, 180 pounds, three stars.&#160;
                                    <meta itemprop="copyrightHolder" content="Andrew Ivins / 247 Sports" /><span class="credit gallery-viewport-credit"> Andrew Ivins / 247 Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663113790952784-QJohnson2.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/b9916763085fe8f83433a77e9d5443140db5b58e/r=500x257/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663113790952784-QJohnson2.jpg" data-byline="247 Sports"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/3a9595fad88dbc34d54e5ef6e41a5dff56ccd68f/c=193-0-1016-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663113790952784-QJohnson2.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/3a9595fad88dbc34d54e5ef6e41a5dff56ccd68f/c=193-0-1016-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663113790952784-QJohnson2.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Quinten Johnson, St. John&#39;s College (Washington D.C.)," data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Quinten Johnson, St. John's College (Washington D.C.), S, 5-11, 190 pounds, three stars.&#160;
                                    <meta itemprop="copyrightHolder" content="247 Sports" /><span class="credit gallery-viewport-credit"> 247 Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092656088048-TrenteJones.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/e0aa0126b5bb63ef84791b9a7712248ad4eff51d/r=500x310/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092656088048-TrenteJones.jpg" data-byline="Keith Niebuhr / 247 Sports"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/63005b4a1e7c1313ef28f1ea8d26f871bfd7329c/c=105-0-1095-744/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092656088048-TrenteJones.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/63005b4a1e7c1313ef28f1ea8d26f871bfd7329c/c=105-0-1095-744/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092656088048-TrenteJones.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Trente Jones, Loganville (Ga.) Grayson, OT, 6-6, 282" data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Trente Jones, Loganville (Ga.) Grayson, OT, 6-6, 282 pounds, four stars.&#160;
                                    <meta itemprop="copyrightHolder" content="Keith Niebuhr / 247 Sports" /><span class="credit gallery-viewport-credit"> Keith Niebuhr / 247 Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092649369341-Cade-McNamara.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/b9916763085fe8f83433a77e9d5443140db5b58e/r=500x257/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092649369341-Cade-McNamara.jpg" data-byline="247Sports"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/464692a090ffec0e8bf2075b4962fd8eb2e5fa41/c=93-0-916-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092649369341-Cade-McNamara.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/464692a090ffec0e8bf2075b4962fd8eb2e5fa41/c=93-0-916-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092649369341-Cade-McNamara.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Cade McNamara, Reno (Nev.) Damonte Ranch, QB, 6-1," data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Cade McNamara, Reno (Nev.) Damonte Ranch, QB, 6-1, 206 pounds, four stars.&#160;
                                    <meta itemprop="copyrightHolder" content="247Sports" /><span class="credit gallery-viewport-credit"> 247Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092653431815-newburg.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/138b74d9a3cbb4a563368e420bb61fd16b77b49b/r=500x308/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092653431815-newburg.jpg" data-byline="247Sports"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/5fd7213147a6c898bdb842d118dd430edea990ae/c=80-0-527-336/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092653431815-newburg.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/5fd7213147a6c898bdb842d118dd430edea990ae/c=80-0-527-336/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092653431815-newburg.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Gabe Newburg, Clayton (Ohio) Northmont, DE, 6-5, 230" data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Gabe Newburg, Clayton (Ohio) Northmont, DE, 6-5, 230 pounds, three stars.&#160;
                                    <meta itemprop="copyrightHolder" content="247Sports" /><span class="credit gallery-viewport-credit"> 247Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092658744281-David-Ojabo.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/53bc65ac0e97a881907a2d264d8251e25be992e5/r=500x258/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092658744281-David-Ojabo.jpg" data-byline="Twitter: @DavidOjabo"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/2801997d85835ff6bd1f55d47e1134f2dbcf2a28/c=194-0-1045-640/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092658744281-David-Ojabo.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/2801997d85835ff6bd1f55d47e1134f2dbcf2a28/c=194-0-1045-640/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092658744281-David-Ojabo.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="David Ojabo, Blairstown (N.J.) Blair Academy, DE, 6-4.5," data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    David Ojabo, Blairstown (N.J.) Blair Academy, DE, 6-4.5, 233 pounds, three stars.&#160;
                                    <meta itemprop="copyrightHolder" content="Twitter: @DavidOjabo" /><span class="credit gallery-viewport-credit"> Twitter: @DavidOjabo</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092655931799-rumler.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/791aea8587b2908b6605c511b3ab4506e488d61d/r=500x284/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092655931799-rumler.jpg" data-byline="247 Sports"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/109ab6278ce97155bd59f6ee7715aa65da2a007f/c=150-0-998-637/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092655931799-rumler.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/109ab6278ce97155bd59f6ee7715aa65da2a007f/c=150-0-998-637/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092655931799-rumler.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Nolan Rumler, Akron (Ohio) Archbishop Hoban, OG, 6-4," data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Nolan Rumler, Akron (Ohio) Archbishop Hoban, OG, 6-4, 290 pounds, four stars.&#160;
                                    <meta itemprop="copyrightHolder" content="247 Sports" /><span class="credit gallery-viewport-credit"> 247 Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663117436866950-mazi.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/53bc65ac0e97a881907a2d264d8251e25be992e5/r=500x258/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663117436866950-mazi.jpg" data-byline="Allen Trieu / 247Sports"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/f5a93e966f3b40f0cd07391effe909ea1e0db75a/c=157-0-843-516/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663117436866950-mazi.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/f5a93e966f3b40f0cd07391effe909ea1e0db75a/c=157-0-843-516/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663117436866950-mazi.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Mazi Smith, Grand Rapids East Kentwood, DT, 6-3, 290" data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Mazi Smith, Grand Rapids East Kentwood, DT, 6-3, 290 pounds, four stars.&#160;
                                    <meta itemprop="copyrightHolder" content="Allen Trieu / 247Sports" /><span class="credit gallery-viewport-credit"> Allen Trieu / 247Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide vertical"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo vertical" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663114722040575-stewart.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/6e4054240700b8037e81cab6a8c1c3e5e38c4e6e/r=289x400/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663114722040575-stewart.jpg"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/ecd85780ec87362394d2543c3adaf66caac71654/c=0-38-739-1024/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663114722040575-stewart.jpg?width=292&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/ecd85780ec87362394d2543c3adaf66caac71654/c=0-38-739-1024/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663114722040575-stewart.jpg?width=1080&amp;height=1440&amp;fit=crop"
                                
                                alt="Jack Stewart, New Canaan (Conn.), OT, 6-5, 280 pounds," data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Jack Stewart, New Canaan (Conn.), OT, 6-5, 280 pounds, three stars.&#160;
                                    <meta itemprop="copyrightHolder" content="Twitter: @jackstewartnc" /><span class="credit gallery-viewport-credit"> Twitter: @jackstewartnc</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092649838088-CharlesThomas.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/b9916763085fe8f83433a77e9d5443140db5b58e/r=500x257/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092649838088-CharlesThomas.jpg" data-byline="247Sports"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/90da6c108e1881ecb911767165a89ee6a84cc8c9/c=369-0-1192-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092649838088-CharlesThomas.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/90da6c108e1881ecb911767165a89ee6a84cc8c9/c=369-0-1192-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092649838088-CharlesThomas.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Charles Thomas, Bradenton (Fla.) IMG Academy, ILB," data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Charles Thomas, Bradenton (Fla.) IMG Academy, ILB, 6-0, 222 pounds, three stars.&#160;
                                    <meta itemprop="copyrightHolder" content="247Sports" /><span class="credit gallery-viewport-credit"> 247Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide vertical"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo vertical" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663092656088048-turner.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/802c6add4b900f4408ea5d791764270498ad1dea/r=225x400/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092656088048-turner.jpg"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/a4e59a74ff8a34d8f1038f6cc0d3dd0565e87488/c=32-220-634-1022/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092656088048-turner.jpg?width=292&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/a4e59a74ff8a34d8f1038f6cc0d3dd0565e87488/c=32-220-634-1022/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092656088048-turner.jpg?width=1080&amp;height=1440&amp;fit=crop"
                                
                                alt="DJ Turner II, Suwanee (Ga.) North Gwinnett, CB, 6-0," data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    DJ Turner II, Suwanee (Ga.) North Gwinnett, CB, 6-0, 165 pounds, three stars.&#160;
                                    <meta itemprop="copyrightHolder" content="Twitter: @djturner_2019" /><span class="credit gallery-viewport-credit"> Twitter: @djturner_2019</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/04/DetroitNews/DetroitNews/636663110335506149-velazquez.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/fe9b19c16f0669d3fe57b9777663b2e3cf99e44d/r=500x371/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663110335506149-velazquez.jpg" data-byline="247Sports"
                                
                                    data-src="https://www.gannett-cdn.com/-mm-/9fc17fd378c83e006505c8d5d3f722e7f21ff059/c=0-0-532-400/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663110335506149-velazquez.jpg?width=520&amp;height=390&amp;fit=crop"
                                    data-large-src="https://www.gannett-cdn.com/-mm-/9fc17fd378c83e006505c8d5d3f722e7f21ff059/c=0-0-532-400/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663110335506149-velazquez.jpg?width=1920&amp;height=1440&amp;fit=crop"
                                
                                alt="Joey Velazquez, Columbus (Ohio) St. Francis De Sales," data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption">
                                    Joey Velazquez, Columbus (Ohio) St. Francis De Sales, S, 6-0, 205 pounds.&#160;
                                    <meta itemprop="copyrightHolder" content="247Sports" /><span class="credit gallery-viewport-credit"> 247Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide partner-slide-ad partner-placement"><div class="gallery-photo-border"></div></div><div class="slide gallery-viewport-slide endslate"><div class="gallery-photo-border"><div class="gallery-endslate"><!-- HTML for the endslate content card --><h3 class="gallery-endslate-header">Interested in this topic? You may also want to view these photo galleries:</h3><ul class="gallery-endslate-related"  data-media-url="https://www.gannett-cdn.com/media/"></ul><div class="gallery-endslate-actions"><div class="gallery-actions-replay">Replay</div></div></div></div></div></div><div class="gallery-thumbs thumbs" data-name="compGalleryThumbs"><div class="thumbswrapper"><ul class="thumbslist scrollable-content"><li class="thumb-item active"><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/157d9fff9b4d9a800de65431d908bfddc470191d/c=0-246-4828-2974/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092719525142-umstock2.jpg?width=80&amp;height=60&amp;fit=crop" alt="Go through the gallery to view the Michigan football" width="80" height="60"><span class="thumb-count">1 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/31392ba0005009e0cde54ff0fc208dccb96ba712/c=52-0-1148-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092649838088-ErickAll.jpg?width=80&amp;height=60&amp;fit=crop" alt="Erick All, Fairfield (Ohio), TE, 6-4, 225 pounds, three" width="80" height="60"><span class="thumb-count">2 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/d949106fde42523a95724bb309125e83ebfec8d3/c=0-30-400-256/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092648588096-barnhart.jpg?width=80&amp;height=60&amp;fit=crop" alt="Karsen Barnhart, Paw Paw, OT, 6-4, 273 pounds, three" width="80" height="60"><span class="thumb-count">3 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/0a3501173b024f5a9630530ad1675d12e1a0f9f0/c=27-0-593-320/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092648588096-carpenter.jpg?width=80&amp;height=60&amp;fit=crop" alt="Zach Carpenter, Cincinnati Archbishop Moeller, OG," width="80" height="60"><span class="thumb-count">4 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/31392ba0005009e0cde54ff0fc208dccb96ba712/c=52-0-1148-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663112542679523-charbonnet2.JPG?width=80&amp;height=60&amp;fit=crop" alt="Zach Charbonnet, Westlake Village (Calif.) Oaks Christian," width="80" height="60"><span class="thumb-count">5 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/31392ba0005009e0cde54ff0fc208dccb96ba712/c=52-0-1148-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092650150586-EricGray.JPG?width=80&amp;height=60&amp;fit=crop" alt="Eric Gray, Memphis (Tenn.) Lausanne Collegiate School," width="80" height="60"><span class="thumb-count">6 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/4d67370caf3b3ef54ded946bd2e1e5e43748c84f/c=68-0-1163-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092653431815-herron.jpg?width=80&amp;height=60&amp;fit=crop" alt="Stephen Herron Jr., Louisville (Ky.) Trinity, DE, 6-3.5," width="80" height="60"><span class="thumb-count">7 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/31392ba0005009e0cde54ff0fc208dccb96ba712/c=52-0-1148-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092653744313-hinton.jpg?width=80&amp;height=60&amp;fit=crop" alt="Chris Hinton, Norcross (Ga.) Greater Atlanta Christian," width="80" height="60"><span class="thumb-count">8 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/31392ba0005009e0cde54ff0fc208dccb96ba712/c=52-0-1148-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092651088080-GJIII.jpg?width=80&amp;height=60&amp;fit=crop" alt="George Johnson III, Stuart (Fla.) Martin County, ATH," width="80" height="60"><span class="thumb-count">9 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/31392ba0005009e0cde54ff0fc208dccb96ba712/c=52-0-1148-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663113790952784-QJohnson2.jpg?width=80&amp;height=60&amp;fit=crop" alt="Quinten Johnson, St. John&#39;s College (Washington D.C.)," width="80" height="60"><span class="thumb-count">10 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/ed7fc664f8eb06f9f567628d89dea0b36d0a752b/c=0-33-1200-711/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092656088048-TrenteJones.jpg?width=80&amp;height=60&amp;fit=crop" alt="Trente Jones, Loganville (Ga.) Grayson, OT, 6-6, 282" width="80" height="60"><span class="thumb-count">11 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/31392ba0005009e0cde54ff0fc208dccb96ba712/c=52-0-1148-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092649369341-Cade-McNamara.jpg?width=80&amp;height=60&amp;fit=crop" alt="Cade McNamara, Reno (Nev.) Damonte Ranch, QB, 6-1," width="80" height="60"><span class="thumb-count">12 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/e28059146eb30e435cc152cca58772088147c73c/c=0-14-544-321/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092653431815-newburg.jpg?width=80&amp;height=60&amp;fit=crop" alt="Gabe Newburg, Clayton (Ohio) Northmont, DE, 6-5, 230" width="80" height="60"><span class="thumb-count">13 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/a7ea6d03cab7edbc7e6c568e85f03abfa530f3b7/c=54-0-1187-640/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092658744281-David-Ojabo.jpg?width=80&amp;height=60&amp;fit=crop" alt="David Ojabo, Blairstown (N.J.) Blair Academy, DE, 6-4.5," width="80" height="60"><span class="thumb-count">14 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/52033bd7b8e824b5b3cbc58e33182fbe6ad9248a/c=0-2-1123-636/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092655931799-rumler.jpg?width=80&amp;height=60&amp;fit=crop" alt="Nolan Rumler, Akron (Ohio) Archbishop Hoban, OG, 6-4," width="80" height="60"><span class="thumb-count">15 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/78877a792643ee05944c14fe724951772eea70ae/c=43-0-956-516/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663117436866950-mazi.jpg?width=80&amp;height=60&amp;fit=crop" alt="Mazi Smith, Grand Rapids East Kentwood, DT, 6-3, 290" width="80" height="60"><span class="thumb-count">16 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/f25fd2222944e3aa46413944d8d3388054d45655/c=0-101-739-519/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663114722040575-stewart.jpg?width=80&amp;height=60&amp;fit=crop" alt="Jack Stewart, New Canaan (Conn.), OT, 6-5, 280 pounds," width="80" height="60"><span class="thumb-count">17 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/45f283bc457c526375838ef12092d6bc2431158b/c=105-0-1200-619/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092649838088-CharlesThomas.jpg?width=80&amp;height=60&amp;fit=crop" alt="Charles Thomas, Bradenton (Fla.) IMG Academy, ILB," width="80" height="60"><span class="thumb-count">18 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/5caed624c6a511d8d719edaf1191f661f0a808cb/c=0-395-672-775/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663092656088048-turner.jpg?width=80&amp;height=60&amp;fit=crop" alt="DJ Turner II, Suwanee (Ga.) North Gwinnett, CB, 6-0," width="80" height="60"><span class="thumb-count">19 of 20</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/-mm-/ed8c4296e4fb9cae433ec2aeb596fa61a3fca898/c=0-9-537-313/local/-/media/2018/07/04/DetroitNews/DetroitNews/636663110335506149-velazquez.jpg?width=80&amp;height=60&amp;fit=crop" alt="Joey Velazquez, Columbus (Ohio) St. Francis De Sales," width="80" height="60"><span class="thumb-count">20 of 20</span></div></a></li></ul></div></div><div class="feature-btns"><div class="ticker feature-btns-control"></div><div class="autoplay feature-btns-control"><span class="playbtn feature-btns-label">Autoplay</span></div><div class="thumbnails feature-btns-control"><span class="thumbLabel feature-btns-label">Show Thumbnails</span></div><div class="captions feature-btns-control"><span class="captionLabel feature-btns-label">Show Captions</span></div></div><a class="slide-nav prev gallery-prev" rel="prev">Last Slide</a><a class="slide-nav next gallery-next" rel="next">Next Slide</a></div></div></div><div id="module-position-RAmSvb-V3mc" class="story-asset story-metadata-asset"><div class="article-metadata-wrap"><section id="module-position-RAmSvbIFgfY" class="storymetadata-bucket expandable-photo-module story-expandable-photo-module"><aside itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject" class="single-photo expandable-collapsed"><div class="image-wrap"><img class="expand-img-horiz" itemprop="url" src="https://www.gannett-cdn.com/-mm-/6a022bcb010b80a3784d3b771496b8b3f21b020a/c=232-0-3859-2727/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666484138964189-2017-1104-dg-UM0564.jpg?width=534&amp;height=401&amp;fit=crop" alt="636666484138964189-2017-1104-dg-UM0564.jpg" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/08/DetroitNews/DetroitNews/636666484138964189-2017-1104-dg-UM0564.jpg" data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/4044b1e7645488621f157de466cf1a990870caa2/r=500x333/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666484138964189-2017-1104-dg-UM0564.jpg" /><span class="toggle"></span><meta itemprop="name" content="636666484138964189-2017-1104-dg-UM0564.jpg" /></div><p class="image-credit-wrap"><span class="js-caption-wrapper"><span class="cutline js-caption">Karan Higdon</span><meta itemprop="copyrightHolder" content="" /><span class="credit">(Photo: David Guralnick, Detroit News)</span></span></p></aside></section></div></div><div id="module-position-RAmSvb-no5w" class="story-asset inline-share-tools-asset"><div class="inline-share-tools asset-inline-share-tools asset-inline-share-tools-top"><span
        class="inline-share-btn inline-share-btn-facebook"
        data-share-method="facebook"
        data-uotrack="InlineShareFacebookBtn"><span class="inline-share-count inline-share-count-facebook"></span><span class="inline-share-btn-label inline-share-btn-label-facebook">CONNECT</span></span><a
        class="inline-share-btn inline-share-btn-twitter"
        data-share-method="twitter"
        data-uotrack="InlineShareTwitterLink"
        data-popup-width="550"
        data-popup-height="450"
        href="https://twitter.com/intent/tweet?url=https%3A//detne.ws/2zmQh1O&amp;text=How%20Jim%20Harbaugh%E2%80%99s%20Michigan%20recruits%20are%20working%20out&amp;via=detroitnews"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-twitter"></span><span class="inline-share-btn-label inline-share-btn-label-twitter">TWEET</span></a><a
        class="inline-share-btn inline-share-btn-linkedin"
        data-share-method="linkedin"
        data-popup-width="600"
        data-popup-height="455"
        data-uotrack="UtilityBarFlyoutLinkedInLink"
        href="http://www.linkedin.com/shareArticle?url=https%3A//detne.ws/2zmQh1O&amp;mini=true"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-linkedin"></span><span class="inline-share-btn-label inline-share-btn-label-linkedin">LINKEDIN</span></a><span
            class="inline-share-btn inline-share-btn-comments"
            data-share-method="comments"
            data-uotrack="InlineShareCommentsBtn"><span class="inline-share-count inline-share-count-comments">
                
                    9
                
            </span><span class="inline-share-btn-label inline-share-btn-label-comments">COMMENT</span></span><span
        class="inline-share-btn inline-share-btn-email"
        data-share-method="email"
        data-uotrack="InlineShareEmailBtn"><span class="inline-share-count inline-share-count-email"></span><span class="inline-share-btn-label inline-share-btn-label-email">EMAIL</span></span><span
         class="inline-share-btn inline-share-btn-more"
         data-share-method="facebook"
         data-uotrack="InlineShareMoreBtn"><span class="inline-share-count inline-share-count-more"></span><span class="inline-share-btn-label inline-share-btn-label-more">MORE</span></span></div></div><p class="speakable-p-1 p-text">This fall will be Jim Harbaugh&rsquo;s fourth as head coach at Michigan. While there are still a handful of players who were recruited before Harbaugh and his staff got to Ann Arbor, the vast majority of the roster is now his recruits. Here is a look back at his first few recruiting classes (all team rankings by the 247Sports Composite).</p><h3 class="presto-h3"><strong>2015</strong></h3><p class="p-text"><strong>Final team rankings: 37th nationally, fifth in Big Ten</strong></p><p class="p-text"><em>Harbaugh was introduced as Michigan&rsquo;s head coach on Dec. 30, 2014. He had to get to recruiting quickly, but it took nearly a month for the first commitment to come in, which was defensive end Reuben Jones.</em></p><p class="p-text"><strong>Reuben Jones, defensive end, Lakeland (Fla.) Lake Gibson: </strong>Then-defensive coordinator D.J. Durkin and Greg Mattison went down to Florida to Lake Gibson, and Jones came up on an official visit to Michigan and flipped from Nebraska. He has appeared in 11 games as a Wolverine.</p><div class="partner-placement partner-spike"></div><p class="p-text"><strong>Karan Higdon, running back, Sarasota (Fla.) Riverview: </strong>The jewel of that first class to this point, Higdon flipped from Iowa on Signing Day, which famously sent Detroit Cass Tech&rsquo;s Mike Weber to Ohio State. He has 1,438 career rushing yards, 994 of those coming during last fall&rsquo;s breakout campaign. He also scored 11 touchdowns last season.</p><p class="p-text"><strong>Grant Perry, wide receiver, Birmingham Brother Rice:</strong> Like Higdon, the Wolverines flipped Perry from a Big Ten foe, this time Northwestern. That happened just days before National Signing Day. Perry has appeared in 34 games at Michigan, catching 52 passes for 618 yards and three touchdowns.</p><div id="module-position-RAmSvb_ibrc" class="story-asset image-asset"><aside itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject" class="wide single-photo"><img itemprop="url" src="https://www.gannett-cdn.com/-mm-/5c256e878dadef171eafef338796ec199d9b3822/c=285-0-4748-3356/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666484757710229-2017-0909-dg-UM1966.jpg?width=540&amp;height=405&amp;fit=crop" alt="Zach Gentry" width="540" height="405" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/08/DetroitNews/DetroitNews/636666484757710229-2017-0909-dg-UM1966.jpg"
                    data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/4044b1e7645488621f157de466cf1a990870caa2/r=500x333/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666484757710229-2017-0909-dg-UM1966.jpg" /><meta itemprop="name" content="636666484757710229-2017-0909-dg-UM1966.jpg" /><meta itemprop="height" content="405" /><meta itemprop="width" content="540" /><p>Zach Gentry<meta itemprop="copyrightHolder" content="David Guralnick, Detroit News" />&nbsp;<span class="credit">(Photo: David Guralnick, Detroit News)</span></p></aside><div class="clearfix"></div></div><p class="p-text"><strong>Zach Gentry, tight end, Albuquerque (N.M.) Eldorado: </strong>Gentry was committed to Texas and was recruited as a quarterback. Michigan brought him in as a second quarterback as Alex Malzone was already committed and enrolled during Harbaugh&rsquo;s first month as head coach. Gentry flipped to the Wolverines, moved to tight end his second year, and made an impact last season catching 17 passes for 303 yards and two touchdowns.</p><p class="p-text"><strong>Shelton Johnson, defensive end, Delray Beach (Fla.) Atlantic:</strong> Even with in-state powers Florida State and Miami after him, Johnson officially visited Michigan and committed to the Wolverines on Signing Day 2015. He did not appear in any games for two seasons, was suspended in 2016, and is no longer with the team.</p><div class="partner-outstream"><div class="partner-video"></div></div><p class="p-text"><strong>Nolan Ulizio, offensive tackle, West Chester (Ohio) Lakota West:</strong> Ulizio was committed to UConn when Michigan came calling. He was offered and took an official visit in January, then flipped to the Wolverines. A two-year letterman, he has started six games at tackle for Michigan.</p><p class="p-text"><strong>More:&nbsp;</strong><a data-track-label="story pages|sports|inline|intext|n/a" href="https://www.detroitnews.com/story/sports/high-school/2018/07/06/early-look-detroit-news-top-high-school-football-players/762307002/">Early look at The Detroit News&rsquo; top high school football players</a></p><p class="p-text"><strong>Other players in 2015 recruiting class:</strong> Brian Cole, WR, Saginaw; Andrew David, K, Massillon (Ohio) Washington; Tyree Kinnel, S, Dayton (Ohio) Wayne; Alex Malzone, QB, Birmingham Brother Rice; Grant Newsome, OT, Trenton (N.J.) Lawrenceville School; Jon Runyan Jr., OT, Philadelphia St. Joseph&rsquo;s; Keith Washington, ATH, Prattville (Ala.); Tyrone Wheatley Jr., TE, Buffalo (N.Y.) Canisius.</p><h3 class="presto-h3"><strong>2016</strong></h3><p class="p-text"><strong>Final team rankings: Eighth nationally, second in Big Ten</strong></p><p class="p-text"><em>The robust 2016 class was Harbaugh&rsquo;s first full recruiting class. While defensive end Rashan Gary was the prize of this group, many others have already become solid contributors.</em></p><div id="module-position-RAmSvb_tquQ" class="story-asset image-asset"><aside itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject" class="wide single-photo"><img itemprop="url" src="https://www.gannett-cdn.com/-mm-/06c6e0a45a501b06a0552c71e0ceb4c8162327b2/c=341-0-4541-3158/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666485503642955-2017-0909-dg-UM2219.jpg?width=540&amp;height=405&amp;fit=crop" alt="Rashan Gary" width="540" height="405" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/08/DetroitNews/DetroitNews/636666485503642955-2017-0909-dg-UM2219.jpg"
                    data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/4044b1e7645488621f157de466cf1a990870caa2/r=500x333/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666485503642955-2017-0909-dg-UM2219.jpg" /><meta itemprop="name" content="636666485503642955-2017-0909-dg-UM2219.jpg" /><meta itemprop="height" content="405" /><meta itemprop="width" content="540" /><p>Rashan Gary<meta itemprop="copyrightHolder" content="David Guralnick, Detroit News" />&nbsp;<span class="credit">(Photo: David Guralnick, Detroit News)</span></p></aside><div class="clearfix"></div></div><p class="p-text"><strong>Rashan Gary, defensive end, Paramus (N.J.) Paramus Catholic: </strong>The No. 1 recruit in the country that year, Gary played as a true freshman, then became the full-time starter as a sophomore, earning first-team All-Big Ten honors. He enters this season expected to be one of the country&rsquo;s top defensive players and a potential high draft choice whenever he enters the draft.</p><p class="p-text"><strong>Ben Bredeson, offensive lineman, Hartland (Wis.) Arrowhead: </strong>Michigan did well to go up to Wisconsin and beat the Badgers for a nationally sought-after recruit. Bredeson has lived up to expectations, starting 20 games, including eight as a true freshman and earning second team All-Big Ten honors as a sophomore.</p><p class="p-text"><strong>Brandon Peters, quarterback Avon (Ind.): </strong>A highly-ranked recruit, Peters started at the end of the 2017 season, and enters 2018 with transfer Shea Patterson as front-runners for the starting job.</p><p class="p-text"><strong>David Long, cornerback, Los Angeles (Calif.) Loyola: </strong>A significant recruiting win for Michigan that year, he held down one of the cornerback spots as a sophomore last fall, earning honorable mention All-Big Ten honors.</p><p class="p-text"><strong>Devin Asiasi, tight end, Concord (Calif.) De La Salle: </strong>It was a surprise to many when Michigan landed Asiasi on National Signing Day. He quickly showed his four-star rating had merit, playing as a true freshman and catching two passes with one touchdown. However, wanting to be closer to home, he transferred to UCLA, where he sat out last season and will play this fall.</p><div id="module-position-RAmSvb_T__s" class="story-asset image-asset"><aside itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject" class="wide single-photo"><img itemprop="url" src="https://www.gannett-cdn.com/-mm-/8a068aa3dee602d9de1b2b10ed5aa5768e48f237/c=189-0-3156-2231/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666486810665840-2017-0909-dg-UM1988.jpg?width=540&amp;height=405&amp;fit=crop" alt="Michael Onwenu" width="540" height="405" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/08/DetroitNews/DetroitNews/636666486810665840-2017-0909-dg-UM1988.jpg"
                    data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/4044b1e7645488621f157de466cf1a990870caa2/r=500x333/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666486810665840-2017-0909-dg-UM1988.jpg" /><meta itemprop="name" content="636666486810665840-2017-0909-dg-UM1988.jpg" /><meta itemprop="height" content="405" /><meta itemprop="width" content="540" /><p>Michael Onwenu<meta itemprop="copyrightHolder" content="David Guralnick, Detroit News" />&nbsp;<span class="credit">(Photo: David Guralnick, Detroit News)</span></p></aside><div class="clearfix"></div></div><p class="p-text"><strong>Michael Onwenu, guard, Detroit Cass Tech: </strong>A multi-year starter at Cass Tech, Onwenu was a national Top 100 recruit per the 247Sports Composite. He started eight games during the 2017 season and is one of the top returners on the offensive line.</p><p class="p-text"><strong>Kareem Walker, running back, Wayne (N.J.) De Paul Catholic: </strong>A highly sought-after recruit and one who was once committed to Ohio State during the recruiting process, Walker was a high four-star prospect, but only had 20 carries for 68 yards and one touchdown during his first two seasons. Various reports have him transferring from the program.</p><p class="p-text"><strong>Kekoa Crawford, wide receiver, Rancho Santa Margarita (Calif.) Catholic: </strong>Caught 21 passes for 290 yards and two touchdowns during his first two seasons at Michigan, but is now appears to be on the verge of transferring.</p><p class="p-text"><strong>Lavert Hill, cornerback, Detroit King:</strong> Hill was committed to Penn State early, but Michigan turned the tide and got him into the class. He emerged as one of the best cover corners in the Big Ten last season and teams with David Long to give the Wolverines an excellent duo.</p><p class="p-text"><strong>Ron Johnson, defensive end, Camden (N.J.): </strong>Highly-productive prep player (196 tackles and 13 sacks in two high school seasons) but has yet to make an impact at Michigan.</p><p class="p-text"><strong>Carlo Kemp, defensive end, Boulder (Colo.) Fairview: </strong>Appeared in 13 games a year ago and is expected to compete for more time this fall.</p><div id="module-position-RAmSvb-WGFI" class="story-asset image-asset"><aside itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject" class="wide single-photo"><img itemprop="url" src="https://www.gannett-cdn.com/-mm-/c812bd7d5bfccbcbafe62f9dfe4ec6376079c41c/c=66-0-3673-2712/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666487234569377-AP-17249292667825.jpg?width=540&amp;height=405&amp;fit=crop" alt="Devin Bush" width="540" height="405" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/08/DetroitNews/DetroitNews/636666487234569377-AP-17249292667825.jpg"
                    data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/965a2fec39369f1f25bf5aaace38a6fa582808b6/r=500x362/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666487234569377-AP-17249292667825.jpg" /><meta itemprop="name" content="Devin Bush, " /><meta itemprop="height" content="405" /><meta itemprop="width" content="540" /><p>Devin Bush<meta itemprop="copyrightHolder" content="Tony Gutierrez, AP" />&nbsp;<span class="credit">(Photo: Tony Gutierrez, AP)</span></p></aside><div class="clearfix"></div></div><p class="p-text"><strong>Devin Bush, linebacker, Hollywood (Fla.) Flanagan: </strong>He has developed into one of the best players on the team, a Butkus Award finalist and should be on the list for other awards and accolades this season.</p><p class="p-text"><strong>Chris Evans, running back, Indianapolis (Ind.) Ben Davis: </strong>Made a quick impact as a true freshman and has rushed for 1,299 yards and 10 touchdowns in two seasons. He teams with Karan Higdon to give the Wolverines a good 1-2 punch in the backfield.</p><p class="p-text"><strong>Nick Eubanks, tight end, Fort Lauderdale (Fla.) American Heritage: </strong>Something of a surprise commit in high school, Eubanks has two receptions for 61 yards in his Michigan career, but has greater upside than that because of his size and athletic tools.</p><p class="p-text"><strong>Eddie McDoom, wide receiver, Winter Garden (Fla.) West Orange: </strong>Speedy slot who played immediately as a true freshman. Has 203 career receiving yards and 140 rushing.</p><div id="module-position-RAmSvb_iiWc" class="story-asset image-asset"><aside itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject" class="wide single-photo"><img itemprop="url" src="https://www.gannett-cdn.com/-mm-/ed390cb8d189e86197a0716f79ab2671ea1939d8/c=0-0-2668-2006/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666487546129883-2017-1104-dg-UM0667.jpg?width=540&amp;height=405&amp;fit=crop" alt="Khaleke Hudson" width="540" height="405" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/08/DetroitNews/DetroitNews/636666487546129883-2017-1104-dg-UM0667.jpg"
                    data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/4044b1e7645488621f157de466cf1a990870caa2/r=500x333/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666487546129883-2017-1104-dg-UM0667.jpg" /><meta itemprop="name" content="636666487546129883-2017-1104-dg-UM0667.jpg" /><meta itemprop="height" content="405" /><meta itemprop="width" content="540" /><p>Khaleke Hudson<meta itemprop="copyrightHolder" content="David Guralnick, Detroit News" />&nbsp;<span class="credit">(Photo: David Guralnick, Detroit News)</span></p></aside><div class="clearfix"></div></div><p class="p-text"><strong>Khaleke Hudson, viper, McKeesport (Pa.): </strong>Started 12 games at viper as a sophomore last season and made 83 tackles (18.5 for loss) with 11 pass breakups and two forced fumbles. He returns this season as one of the key pieces to the Michigan defense.</p><p class="p-text"><strong>Elysee Mbem-Bosse, linebacker, Ellenwood (Ga.) Cedar Grove: </strong>Appeared in 11 games as a Wolverine before leaving the team last November. He made threatening tweets against Jim Harbaugh in April and University of Michigan Police investigated. He apologized via Twitter and the case was closed in May.</p><p class="p-text"><strong>Nate Johnson, wide receiver, Thompson&rsquo;s Station (Tenn.) Independence: </strong>Johnson played as a true freshman at receiver, catching one pass in 2016. He moved to cornerback as a sophomore but was dismissed from the team following a domestic assault and battery charge. He is now at Arizona Western.</p><p class="p-text"><strong>Quinn Nordin, kicker, Rockford: </strong>Considered the nation&rsquo;s top kicking recruit by some services, Nordin is 19-for-24 on field goals in his Michigan career, including a career long of 55 yards. He has a strong leg and can be a weapon for the Wolverines if he can continue to improve his consistency. He made his last five field goals attempted last fall.</p><p class="p-text"><strong>Joshua Uche, defensive end, Miami (Fla.) Columbus: </strong>Uche has seen the field in 14 career games, making six tackles, but his speed has some program insiders optimistic he can make more of an impact this season.</p><p class="p-text"><strong>Kingston Davis, fullback, Prattville (Ala.): </strong>Left Michigan after playing in one game as a true freshman. Went to Independence Community College, where he rushed for 37 yards, and is now at UAB.</p><p class="p-text"><strong>Stephen Spanellis, guard, Baltimore (Md.) Gilman: </strong>Has played center, guard and tackle while contributing on special teams. Was the recipient of the top GPA team award last season.</p><p class="p-text"><strong>Josh Metellus, safety, Hollywood (Fla.) Flanagan:</strong> Played in several games as a true freshman, but broke out last season as the full-time starter, earning honorable mention All-Big Ten honors.</p><p class="p-text"><strong>Sean McKeon, tight end, Dudley (Mass.) Shepherd Hill:</strong> McKeon was not one of the higher-ranked recruits in the class, but made an impact last fall, catching 31 passes for 301 yards and three touchdowns, good enough to earn him honorable mention All-Big Ten honors.</p><p class="p-text"><strong>Michael Dwumfour, defensive tackle, Wayne (N.J.) DePaul Catholic: </strong>A Penn State flip during recruiting, Dwumfour has appeared in 10 games as a Wolverine, making six tackles (two for loss). He is expected to be one of the players replacing Maurice Hurst this fall after turning in a good spring.</p><p class="p-text"><strong>Devin Gil, safety, Hollywood (Fla.) Flanagan: </strong>Hybrid player in high school who has been a linebacker at Michigan. Has appeared in 13 games and has been a special teams contributor.</p><p class="p-text"><strong>Brad Hawkins, safety, Camden (N.J.): </strong>Hawkins was committed to Michigan out of Camden, but went to one year of prep school at Suffield Academy before making his Wolverines debut last fall. A wide receiver recruit, his size and strength give him an opportunity to push for more time this season after getting acclimated a year ago.</p><h3 class="presto-h3"><strong>2017</strong></h3><p class="p-text"><strong>Final team rankings: Fifth nationally, second in Big Ten</strong></p><p class="p-text"><em>The 2017 class boasted a pair of five-star prospects (Donovan Peoples-Jones and Aubrey Solomon) and 19 four-stars. While these young Wolverines are just getting rolling in their college careers, many have already flashed impressive ability.</em></p><p class="p-text"><strong>Donovan Peoples-Jones, wide receiver, Detroit Cass Tech: </strong>Expectations were very high for this five-star recruit. He finished the season with 22 receptions for 277 yards and 57 rushing yards. He also had 320 yards and one touchdown as a punt returner. He is expected to make a big jump forward as a sophomore.</p><div id="module-position-RAmSvb_NnNI" class="story-asset image-asset"><aside itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject" class="wide single-photo"><img itemprop="url" src="https://www.gannett-cdn.com/-mm-/253e75a5f0365a2005a0c72ef3da6a307a52c39f/c=35-0-3497-2603/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666488413780580-tdndc5-6xrx71jdrq8a327oadd-original.jpg?width=540&amp;height=405&amp;fit=crop" alt="Aubrey Solomon" width="540" height="405" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/08/DetroitNews/DetroitNews/636666488413780580-tdndc5-6xrx71jdrq8a327oadd-original.jpg"
                    data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/fe9b19c16f0669d3fe57b9777663b2e3cf99e44d/r=500x371/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666488413780580-tdndc5-6xrx71jdrq8a327oadd-original.jpg" /><meta itemprop="name" content="636666488413780580-tdndc5-6xrx71jdrq8a327oadd-original.jpg" /><meta itemprop="height" content="405" /><meta itemprop="width" content="540" /><p>Aubrey Solomon<meta itemprop="copyrightHolder" content="Daniel Mears, Detroit News" />&nbsp;<span class="credit">(Photo: Daniel Mears, Detroit News)</span></p></aside><div class="clearfix"></div></div><p class="p-text"><strong>Aubrey Solomon, defensive tackle, Leesburg (Ga.) Lee County: </strong>Flashed the ability that made him a highly-decorated recruit, appearing in all 13 games as a true freshman and making 18 tackles (two for loss). He started against Wisconsin, recording four tackles in that game. He is expected to make even more of an impact this season.</p><p class="p-text"><strong>Cesar Ruiz, center, Bradenton (Fla.) IMG Academy: </strong>Ruiz was pegged as the Michigan center of the future during the recruiting process, but ended up starting at guard for six games as a true freshman. He can still play either position, but should be the team&rsquo;s starting center this year, and is on track to live up to his recruiting rankings.</p><p class="p-text"><strong>Luiji Vilain, defensive end, Alexandria (Va.) Episcopal: </strong>Vilain redshirted last season, but there was good buzz about him during camp. He missed time during the spring with an injury, however.</p><p class="p-text"><strong>Drew Singleton, linebacker, Paramus (N.J.) Catholic: </strong>After tearing his ACL as a senior in high school, Singleton redshirted last season, but is fully healthy and expected to be one of the young players in competition at linebacker this fall.</p><p class="p-text"><strong>Ambry Thomas, cornerback, Detroit King: </strong>A top 100 high school recruit, Thomas saw time at cornerback and special teams as a true freshman. Wolverine fans can expect to see him more this season, and he is considered one of the fastest, more athletically-gifted players in the secondary.</p><p class="p-text"><strong>Jordan Anthony, linebacker, Bradenton (Fla.) IMG Academy: </strong>Another young linebacker who will have an opportunity to compete for the spot vacated by Mike McCray&rsquo;s graduation or provide further depth at another spot.</p><p class="p-text"><strong>Chuck Filiaga, offensive tackle, Aledo (Texas): </strong>A big addition to this recruiting class during the U.S. Army All-American Bowl, there was some buzz that Filaga would compete for time last season, but he ended up redshirting. He has worked at both guard and tackle and is in the mix this year.</p><div id="module-position-RAmSvb-2IQU" class="story-asset image-asset"><aside itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject" class="single-photo float"><img itemprop="url" src="https://www.gannett-cdn.com/-mm-/6ae999efbf71551cffce2d5f0186d9e3cfba0896/c=0-212-1881-2720/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666489011745503-2017-0909-dg-UM0067.jpg?width=180&amp;height=240&amp;fit=crop" alt="Tarik Black" width="180" height="240" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/08/DetroitNews/DetroitNews/636666489011745503-2017-0909-dg-UM0067.jpg"
                    data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/b2e9b23cd767d8a10443c055f0220c24d0200e88/r=266x400/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666489011745503-2017-0909-dg-UM0067.jpg" /><meta itemprop="name" content="636666489011745503-2017-0909-dg-UM0067.jpg" /><meta itemprop="height" content="240" /><meta itemprop="width" content="180" /><p>Tarik Black<meta itemprop="copyrightHolder" content="David Guralnick, Detroit News" />&nbsp;<span class="credit">(Photo: David Guralnick, Detroit News)</span></p></aside></div><p class="p-text"><strong>Tarik Black, wide receiver, Cheshire (Conn.) Academy: </strong>Black got off to a fast start in his true freshman season, catching 11 passes for 149 yards and a touchdown in three games before a foot injury sidelined him for the rest of the year. Now healthy, he looked like a potential star in the spring and teams with Donovan Peoples-Jones to give the Wolverines a dynamic pair of outside receivers.</p><p class="p-text"><strong>Dylan McCaffrey, quarterback, Littleton (Colo.) Valor Christian:</strong> Redshirted last season. He is not expected to compete for the starting job this fall with Brandon Peters and Shea Patterson there, but long-term, McCaffrey and true freshman Joe Milton will be in competition for that job at some point.</p><p class="p-text"><strong>Nico Collins, wide receiver, Pinson (Ala.) Clay-Chalkville: </strong>Collins got time in several games, catching one pass as a true freshman. He was injured in the spring but gives the Wolverines another big, talented body at the position.</p><p class="p-text"><strong>Oliver Martin, wide receiver, Iowa City West: </strong>Even though there was good buzz about him during camp last year, Martin ended up redshirting. That buzz grew this spring. Wolverine fans should expect to see Martin in the slot this fall and he may even push for a starting job.</p><p class="p-text"><strong>Josh Ross, linebacker, Orchard Lake St. Mary&rsquo;s: </strong>Ross made some big hits on special teams as a true freshman and got his feet wet some on defense. His workload is expected to increase this season.</p><p class="p-text"><strong>James Hudson, offensive tackle, Toledo Central Catholic: </strong>Recruited as a defensive lineman, Hudson has moved to offensive tackle, where he played well as a high school senior and has a bright future at Michigan. He may even be a candidate to get into the starting mix this season.</p><p class="p-text"><strong>Deron Irving-Bey, defensive end, Flint Southwestern Academy: </strong>When Irving-Bey was being recruited, the book on him was, he was a talented player who may need some time to reach his full potential. After redshirting last season, this is the year we will first get to see how close he is to capitalizing on his athletic gifts.</p><div id="module-position-RAmSvcAVaXg" class="story-asset image-asset"><aside itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject" class="single-photo float"><img itemprop="url" src="https://www.gannett-cdn.com/-mm-/6fc5ed940405232337a0850265aae54d6f1fa2f4/c=0-342-2413-3560/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666489593773028-2017-1021-dg-UM0376.jpg?width=180&amp;height=240&amp;fit=crop" alt="Jaylen Kelly-Powell" width="180" height="240" data-mycapture-src="https://www.gannett-cdn.com/media/2018/07/08/DetroitNews/DetroitNews/636666489593773028-2017-1021-dg-UM0376.jpg"
                    data-mycapture-sm-src="https://www.gannett-cdn.com/-mm-/b2e9b23cd767d8a10443c055f0220c24d0200e88/r=266x400/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666489593773028-2017-1021-dg-UM0376.jpg" /><meta itemprop="name" content="636666489593773028-2017-1021-dg-UM0376.jpg" /><meta itemprop="height" content="240" /><meta itemprop="width" content="180" /><p>Jaylen Kelly-Powell<meta itemprop="copyrightHolder" content="David Guralnick, Detroit News" />&nbsp;<span class="credit">(Photo: David Guralnick, Detroit News)</span></p></aside></div><p class="p-text"><strong>Jaylen Kelly-Powell, safety, Detroit Cass Tech: </strong>Michigan was able to have him practice at several spots last year. He saw meaningful snaps in several games and gives Michigan depth at safety and cornerback going into this season.</p><p class="p-text"><strong>Corey Malone-Hatcher, defensive end, St. Joseph: </strong>Retired from football due to injury before last season.</p><p class="p-text"><strong>O&rsquo;Maury Samuels, running back, Los Lunas (N.M.): </strong>Carried the ball eight times for 13 yards as a true freshman. He dealt with some injuries in the spring, so it is still to be determined how much of a contributor he will be this fall.</p><p class="p-text"><strong>Donovan Jeter, defensive end, Beaver Falls (Pa.): </strong>Jeter may have played some last fall, but was lost for the season with an injury. He is back at full strength and should see the field this year.</p><p class="p-text"><strong>JaRaymond Hall, offensive tackle, Oak Park:</strong> Enrolled early and went through spring practice, but did not play during the fall. He transferred to Central Michigan following the season.</p><p class="p-text"><strong>Benjamin St-Juste, cornerback, Montreal (QC) Cegep Du Vieux: </strong>Enrolled early and flashed his talent, intercepting a pass in the spring game. Then he played, mostly on special teams, as a true freshman, but gives the Wolverines size and depth at cornerback going into this season.</p><p class="p-text"><strong>Andrew Stueber, offensive tackle, Darien (Conn.): </strong>After redshirting last fall, Stueber rotated at tackle in the spring and is one of the names in the mix for an open competition at that position, as well as guard.</p><p class="p-text"><strong>J&rsquo;Marick Woods, safety, Florence (Ala.):</strong> Lettered as a true freshman and ended his first season strong, making five tackles against Ohio State and then starting in the Outback Bowl. Consensus among program insiders is that his future is bright.</p><p class="p-text"><strong>Joel Honigford, offensive tackle, Sugarcreek (Ohio) Garaway:</strong> Honigford did not play as a true freshman and after playing tackle in high school, appears to be competing more at guard now.</p><p class="p-text"><strong>Phil Paea, defensive tackle, Berrien Springs: </strong>Paea was recruited with the possibility of him playing either side of the ball. That versatility already has shown up as he worked as a defensive tackle last fall, but is now with the guards.</p><p class="p-text"><strong>Kwity Paye, defensive end, Warwick (R.I.) Bishop Hendricken: </strong>Paye played as a true freshman, recording five tackles and a sack. Now bigger and stronger, there is a lot of talk around the program that he is ready to take a massive step forward this year.</p><p class="p-text"><strong>Ben Mason, fullback, Newtown (Conn.) Sandy Hook: </strong>Mason appeared in every game, starting one, as a true freshman, and earned the team&rsquo;s toughest player award. He missed part of the spring with an injury, but will be fully healthy for fall camp.</p><p class="p-text"><strong>Kurt Taylor, running back, Covington (Ga.) Grayson: </strong>Taylor did not see the field as a true freshman.</p><p class="p-text"><strong>Brad Robbins, punter, Westerville (Ohio) South: </strong>Honorable mention All-Big Ten selection after averaging 40.4 yards per punt last season.</p><p class="p-text">&nbsp;</p><p class="p-text p-text-last"id="article-body-p-last">&nbsp;</p><div id="module-position-RAmSvcA_-zs" class="story-asset detroitnews-inline-video-player-asset"><script type="text/javascript" async src="http://launch.newsinc.com/js/embed.js" id="_nw2e-js"></script><div class="embed"><div class="ndn_embed" id="ndn-video-player-2" data-config-distributor-id="90851"></div></div></div><div id="module-position-RAmSvcACVG8" class="story-asset inline-share-tools-asset"><div class="inline-share-tools asset-inline-share-tools asset-inline-share-tools-bottom"><span
        class="inline-share-btn inline-share-btn-facebook"
        data-share-method="facebook"
        data-uotrack="InlineShareFacebookBtn"><span class="inline-share-count inline-share-count-facebook"></span><span class="inline-share-btn-label inline-share-btn-label-facebook">CONNECT</span></span><a
        class="inline-share-btn inline-share-btn-twitter"
        data-share-method="twitter"
        data-uotrack="InlineShareTwitterLink"
        data-popup-width="550"
        data-popup-height="450"
        href="https://twitter.com/intent/tweet?url=https%3A//detne.ws/2zmQh1O&amp;text=How%20Jim%20Harbaugh%E2%80%99s%20Michigan%20recruits%20are%20working%20out&amp;via=detroitnews"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-twitter"></span><span class="inline-share-btn-label inline-share-btn-label-twitter">TWEET</span></a><a
        class="inline-share-btn inline-share-btn-linkedin"
        data-share-method="linkedin"
        data-popup-width="600"
        data-popup-height="455"
        data-uotrack="UtilityBarFlyoutLinkedInLink"
        href="http://www.linkedin.com/shareArticle?url=https%3A//detne.ws/2zmQh1O&amp;mini=true"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-linkedin"></span><span class="inline-share-btn-label inline-share-btn-label-linkedin">LINKEDIN</span></a><span
            class="inline-share-btn inline-share-btn-comments"
            data-share-method="comments"
            data-uotrack="InlineShareCommentsBtn"><span class="inline-share-count inline-share-count-comments">
                
                    9
                
            </span><span class="inline-share-btn-label inline-share-btn-label-comments">COMMENT</span></span><span
        class="inline-share-btn inline-share-btn-email"
        data-share-method="email"
        data-uotrack="InlineShareEmailBtn"><span class="inline-share-count inline-share-count-email"></span><span class="inline-share-btn-label inline-share-btn-label-email">EMAIL</span></span><span
         class="inline-share-btn inline-share-btn-more"
         data-share-method="facebook"
         data-uotrack="InlineShareMoreBtn"><span class="inline-share-count inline-share-count-more"></span><span class="inline-share-btn-label inline-share-btn-label-more">MORE</span></span></div></div></div><aside class="story-right-rail"><section id="module-position-RAmSvbGFVcM" class="storyrightrail-bucket poster-ad-asset-module story-poster-ad-asset-module"><div class="partner-placement partner-asset-right-ad"></div></section><section id="module-position-RAmSvbJqM1U" class="storyrightrail-bucket taboola-poster-asset-module story-taboola-poster-asset-module"><div id="taboola-abp-right-rail-thumbnails"></div></section><section id="module-position-RAmSvbIx2rU" class="storyrightrail-bucket more-section-stories-module story-more-section-stories-module"><div class="story-ribbon" style=""><h6 class="story-ribbon-title">
    
        More Stories
    
</h6><div class="story-ribbon-content"><ul class="more-section-stories-list"><li class="more-section-stories-item first"><a class="more-section-stories-image-link" href="/story/sports/nba/pistons/2018/07/08/glenn-robinson-iii-takes-big-step-up-pistons/766509002/"   data-ht="moresportsstories"><img src="https://www.gannett-cdn.com/-mm-/b011b8dbbd4c1234406a95019ae31cea3993a99e/c=0-233-3269-3502/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666850554604436-AP-18103049639861.jpg?width=80&amp;height=80&amp;fit=crop" width="80" height="80" alt="Glenn Robinson III takes a big step up with Pistons" class="more-section-stories-thumb"/><div class="play-btn-m clst-thumb-play-btn-m"></div></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/sports/nba/pistons/2018/07/08/glenn-robinson-iii-takes-big-step-up-pistons/766509002/"    data-ht="moresportsstories">
                    Glenn Robinson III takes a big step up with Pistons</a></h6><div class="more-section-stories-meta">
                    July 9, 2018, 5:25 a.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/sports/college/university-michigan/wolverines/2018/07/08/michigan-wolverines-among-final-three-five-star-point-guard-dj-carton/766714002/"   data-ht="moresportsstories"><img src="https://www.gannett-cdn.com/-mm-/1ca37968637316dff21e6b4d9ecbb977135de4d0/c=202-0-818-616/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666704726631491-Carton.jpg?width=80&amp;height=80&amp;fit=crop" width="80" height="80" alt="Michigan among final three for five-star point guard DJ Carton" class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/sports/college/university-michigan/wolverines/2018/07/08/michigan-wolverines-among-final-three-five-star-point-guard-dj-carton/766714002/"    data-ht="moresportsstories">
                    Michigan among final three for five-star point guard DJ Carton</a></h6><div class="more-section-stories-meta">
                    July 8, 2018, 6:16 p.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/sports/mlb/tigers/2018/07/08/joe-jimenez-not-nick-castellanos-detroit-tigers-lone-all-star/766499002/"   data-ht="moresportsstories"><img src="https://www.gannett-cdn.com/-mm-/abd5fe104e2a6123fa46859b6284e6b0f5cb3ab0/c=397-0-3198-2801/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666679512417863-2018-0706-rb-tigers-rangers856.jpg?width=80&amp;height=80&amp;fit=crop" width="80" height="80" alt="All-Star Game: Dream come true for Jimenez, dream deferred for Castellanos" class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/sports/mlb/tigers/2018/07/08/joe-jimenez-not-nick-castellanos-detroit-tigers-lone-all-star/766499002/"    data-ht="moresportsstories">
                    Jimenez, not Castellanos, is Tigers' lone All-Star</a></h6><div class="more-section-stories-meta">
                    July 8, 2018, 7:53 p.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/sports/mlb/tigers/2018/07/08/tigers-minor-league-report-grayson-greiner-making-case-work-detroit/766462002/"   data-ht="moresportsstories"><img src="https://www.gannett-cdn.com/-mm-/ce56d0a67822e52e748e0e87119996e3b2422895/c=0-202-3098-3300/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666656443503005-2018-0216-rb-minor-league650.jpg?width=80&amp;height=80&amp;fit=crop" width="80" height="80" alt="Tigers minor-league report: Greiner making case for work in Detroit" class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/sports/mlb/tigers/2018/07/08/tigers-minor-league-report-grayson-greiner-making-case-work-detroit/766462002/"    data-ht="moresportsstories">
                    Tigers minor-league report: Greiner making case for work in Detroit</a></h6><div class="more-section-stories-meta">
                    July 8, 2018, 6:54 p.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/sports/nba/pistons/2018/07/08/detroit-pistons-sign-golden-state-warriors-free-agent-zaza-pachulia/766404002/"   data-ht="moresportsstories"><img src="https://www.gannett-cdn.com/-mm-/2e26749735b38059f5d9b11bfe8a45237bc10f6a/c=0-330-1681-2011/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666536508629021-AP-18056150436811.jpg?width=80&amp;height=80&amp;fit=crop" width="80" height="80" alt="Pistons to sign Warriors free agent Zaza Pachulia" class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/sports/nba/pistons/2018/07/08/detroit-pistons-sign-golden-state-warriors-free-agent-zaza-pachulia/766404002/"    data-ht="moresportsstories">
                    Pistons to sign Warriors free agent Zaza Pachulia</a></h6><div class="more-section-stories-meta">
                    July 8, 2018, 8:27 p.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/"   data-ht="moresportsstories"><img src="https://www.gannett-cdn.com/-mm-/2c79688bc53497ff6b8ccd4b5dae5294b8985a54/c=566-0-3293-2727/local/-/media/2018/07/08/DetroitNews/DetroitNews/636666484138964189-2017-1104-dg-UM0564.jpg?width=80&amp;height=80&amp;fit=crop" width="80" height="80" alt="How Jim Harbaugh’s Michigan recruits are working out" class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/sports/college/university-michigan/wolverines/2018/07/08/how-jim-harbaughs-university-michigan-football-recruits-working-out/766335002/"    data-ht="moresportsstories">
                    How Jim Harbaugh’s Michigan recruits are working out</a></h6><div class="more-section-stories-meta">
                    July 9, 2018, 5:21 a.m.
                </div></li></ul></div></div></section><section id="module-position-RAmSvbI_l0c" class="storyrightrail-bucket poster-ad-asset2-module story-poster-ad-asset2-module"><div class="partner-asset-right-ad-2"><div class="poster-scroll"><div class="partner-placement poster-scroll-ad"></div></div></div></section></aside><section id="module-position-RAmSvbIlI8M" class="storybottombar-bucket taboola-related-module story-taboola-related-module"><div class="more more-stories-wrap"><div class="more-stories-content"><div id="js-taboola-wrapper"><div id="taboola-grid-3x3"></div><div id="taboola-organic-grid-3x3"></div><div id="taboola-short-article-2x5"></div><div id="taboola-organic-short-article-2x5"></div><div id="taboola-grid-sports-3x3"></div><div id="taboola-organic-grid-sports-3x3"></div></div></div></div><div class="clearfix"></div></section><section id="module-position-RAmSvbJE6vE" class="storybottombar-bucket leaderboard-ad-module story-leaderboard-ad-module"><div class="partner-placement asset-leaderboard-btf-ad leaderboard-ad common-ad-styling"></div></section><!-- comscorekw=sports --><script type="json/pageinfo" class="pageinfo">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</script></article></div><div class="arrows overlay-arrows"><script type="text/template" id="overlay-arrow-wrap"><% if (disabled) { %><a class="overlay-content-arrows overlay-arrows-<%= dir %>-wrap <%= disabled %>" data-ht="articlearrow<%= dir %>"></a><% }else{ %><a class="overlay-content-arrows overlay-content-arrows-<%= dir %>-wrap <%= disabled %>" href="<%= links %>" data-ht="articlearrow<%= dir %>"><div class="overlay-arrow-<%= dir %> overlay-arrows-anchor"><div class="overlay-arrows-<%= dir %>-anchor-image"></div></div></a><% } %></script></div><div class="partner-overlay"><div class="partner-placement"><a href="#" class="partner-close partner-overlay-close"></a></div><div class="ui-film show"></div></div></div><div id="overlay-film" class="ui-film show"></div><div id="ad-staging"></div><script type="text/javascript" src="https://www.googletagservices.com/tag/js/gpt.js"></script><script type="text/javascript" src="https://www.gannett-cdn.com/partner/vendor/pbjsandwich.min.js"></script><!--[if lt IE 9]><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/jsb/main_legacy.min.js"></script><![endif]--><!--[if gt IE 8]><!--><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/detroitnews-web-static-2529.0/jsb/main.min.js"></script><!--<![endif]--><script src="https://login.gcion.com/GANNETT-GUP/resources/kit/js/norequirejs.common.min.js" id="jskit"></script><script type="text/javascript">
        
        require(["gdp-usf/kit/js/user_factory_def", "gdp-usf/kit/js/feature_personalized_link_def", "gdp-usf/kit/js/client_helpers"],
            function(UserFactory, PersonalizedLinkFactory, ClientHelpers) {
                window.UserFactory = UserFactory;
                window.PersonalizedLinkFactory = PersonalizedLinkFactory;
                window.ClientHelpers = ClientHelpers;
            }
        );
        </script><div id="fb-root"></div><script src="https://www.gannett-cdn.com/appservices/gidgits-js/gidgits.min.js" id="gidgits-script"></script><script type="text/javascript">
        var mainAd = document.createElement('div');
        mainAd.id = 'main_ad';
        mainAd.style.cssText = 'height:1px; width:1px; overflow:auto;position: absolute;left: -999em;';
        document.body.appendChild(mainAd);
        var blockPosition = document.getElementById('main_ad');
        if(blockPosition && blockPosition.offsetHeight == 1) {
            window.adsEnabled = true;
        }
    </script></body></html>
